summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArnel A. Borja <kyoushuu@yahoo.com>2013-05-20 09:00:12 +0800
committerJakub Steiner <jimmac@gmail.com>2013-05-20 13:02:14 +0200
commit1577d7c022681dc13860292766ff6fd937b797ac (patch)
tree9d8fa798fa4b43dc2f52121f185e0d3771ae6c8b /Makefile.am
parent72bbc4dea53f32fb2222384457e108ae2122c19f (diff)
downloadadwaita-icon-theme-1577d7c022681dc13860292766ff6fd937b797ac.tar.gz
install-data-hook fix by Yanko Kaneti <yaneti@declera.com>
https://bugzilla.gnome.org/show_bug.cgi?id=700680
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0c5a3c6e9..6e7bb1dc5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -81,7 +81,9 @@ install-data-local:
fi
install-data-hook:
- $(GTK_UPDATE_ICON_CACHE) -q $(DESTDIR)$(themedir)
+ if test -z "$(DESTDIR)" ; then \
+ $(GTK_UPDATE_ICON_CACHE) -q $(DESTDIR)$(themedir); \
+ fi
uninstall-hook:
@rm -f $(DESTDIR)$(themedir)/icon-theme.cache