summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorWilliam Jon McCann <jmccann@redhat.com>2010-03-28 22:42:57 -0400
committerWilliam Jon McCann <jmccann@redhat.com>2010-03-29 00:03:43 -0400
commit2e737c5fce25ca5f2a392d52ab3e1c69156638d0 (patch)
tree381bf3e8582a4aee87953d1973770689ff2a4d37 /Makefile.am
parentf6a61b933ebf9921a0d8b5368cfa456da96c91c4 (diff)
downloadadwaita-icon-theme-2e737c5fce25ca5f2a392d52ab3e1c69156638d0.tar.gz
Switch to a more standard build system
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 000000000..f6ab79bc4
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,36 @@
+DISTCHECK_CONFIGURE_FLAGS = --disable-icon-mapping
+
+SUBDIRS = $(SVGSRCDIR)
+
+THEME_DIRS=$(shell SIZES="$(render_sizes)"; for size in $$SIZES; do for dir in `find $(srcdir)/$(SVGOUTDIR)/$$size/* -type d`; do printf "$$dir,"; done; done | sed -e "s/,$$//g")
+
+render: Makefile
+ ($(am__cd) $(SVGSRCDIR) && $(MAKE) $(AM_MAKEFLAGS) render) \
+ || eval `exit 1`
+
+# we don't want to install mo files, all translations are already stored
+# in theme files
+install-data-local:
+ if [ -h $(DESTDIR)$(themedir) ]; then \
+ rm -f $(DESTDIR)$(themedir); \
+ fi
+ if [ -d $(DESTDIR)$(themedir) ]; then \
+ touch $(DESTDIR)$(themedir); \
+ fi
+
+EXTRA_DIST = gnome
+
+MAINTAINERCLEANFILES = \
+ Makefile.in \
+ aclocal.m4 \
+ config.guess \
+ config.h.in \
+ config.sub \
+ configure \
+ depcomp \
+ install-sh \
+ intltool-*.in \
+ libtool \
+ ltmain.sh \
+ missing \
+ mkinstalldirs