summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKalev Lember <kalevlember@gmail.com>2014-10-28 11:42:19 +0100
committerJakub Steiner <jimmac@gmail.com>2014-10-29 15:32:22 +0100
commit3227136e998ea655ed7d2b6b0be5909f6608da7b (patch)
treeb481a72b7b65f017e177e6ed6123e3aa1a696bb4 /Makefile.am
parentb0e6cc50f957a8a4f61439bcb8536e4737fb8ecc (diff)
downloadadwaita-icon-theme-3227136e998ea655ed7d2b6b0be5909f6608da7b.tar.gz
Avoid a hard dependency on gtk-update-icon-cache
This makes is possible to build adwaita-icon-theme before gtk+ and avoids a circular dependency between those two modules. https://bugzilla.gnome.org/show_bug.cgi?id=739290
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7cf1a440f..fed397253 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -99,7 +99,7 @@ install-data-local:
fi
install-data-hook:
- if test -z "$(DESTDIR)" ; then \
+ if test -z "$(DESTDIR)" && test -n "$(GTK_UPDATE_ICON_CACHE)" ; then \
$(GTK_UPDATE_ICON_CACHE) -q $(DESTDIR)$(themedir); \
fi