summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Steiner <jimmac@gmail.com>2018-10-19 09:01:21 +0200
committerJakub Steiner <jimmac@gmail.com>2018-10-19 09:01:21 +0200
commit8d12f0a2bfe3369ae2932811e4c7035543da8e05 (patch)
tree961999741274261e0b072d20d75d035b18222cc7 /Makefile.am
parentdfb85283f30fd4ea920240673d874aee4a96b65c (diff)
downloadadwaita-icon-theme-8d12f0a2bfe3369ae2932811e4c7035543da8e05.tar.gz
retire fullcolor action icons
- step1 -- move to legacy context See Issue #15 for more context
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 73f4482ce..103f6d0fe 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,7 +29,7 @@ endif
theme_in_files = index.theme.in
theme_DATA = $(theme_in_files:.theme.in=.theme)
-THEME_DIRS=$(shell SIZES="$(install_sizes)"; for size in $$SIZES; do for dir in `find $(srcdir)/$(SVGOUTDIR)/$$size/* -type d`; do printf "$$dir,"; done; done; echo "scalable/actions,scalable/apps,scalable/categories,scalable/devices,scalable/emblems,scalable/emotes,scalable/mimetypes,scalable/places,scalable/status,scalable-up-to-32/status,")
+THEME_DIRS=$(shell SIZES="$(install_sizes)"; for size in $$SIZES; do for dir in `find $(srcdir)/$(SVGOUTDIR)/$$size/* -type d`; do printf "$$dir,"; done; done; echo "scalable/actions,scalable/apps,scalable/categories,scalable/devices,scalable/emblems,scalable/emotes,scalable/mimetypes,scalable/places,scalable/status,scalable/legacy,scalable-up-to-32/status,")
%.theme: %.theme.in $(SVGOUTDIR) Makefile
dirs="`echo $(THEME_DIRS) | sed -e 's#$(srcdir)/Adwaita/##g'`"; \
@@ -78,6 +78,9 @@ THEME_DIRS=$(shell SIZES="$(install_sizes)"; for size in $$SIZES; do for dir in
if test "$$context" = "status"; then \
echo "Context=Status" >> $@; \
fi; \
+ if test "$$context" = "legacy"; then \
+ echo "Context=Legacy" >> $@; \
+ fi; \
echo "Size=$$size" >> $@; \
if test "$$sizefull" = "scalable"; then \
echo "MinSize=8" >> $@; \