summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2014-06-23 18:52:19 -0400
committerMatthias Clasen <mclasen@redhat.com>2014-06-23 18:52:19 -0400
commit90dfe03ed95c6c21d8350c8fba81482ec98b400f (patch)
treefee755a7c115d066857e7509957466f6e510a5cd /Makefile.am
parentd15c9c68e07197c4cdb5fbaa8197a2712c40b71c (diff)
downloadadwaita-icon-theme-90dfe03ed95c6c21d8350c8fba81482ec98b400f.tar.gz
Fix up a few typos in index.theme generation
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index fc7a8b5ab..eaff9ff40 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,7 +10,7 @@ cursor_DATA = $(wildcard $(srcdir)/Adwaita/cursors/*)
theme_in_files = index.theme.in.in
theme_DATA = $(theme_in_files:.theme.in.in=.theme)
-THEME_DIRS=$(shell SIZES="$(render_sizes)"; for size in $$SIZES; do for dir in `find $(srcdir)/$(SVGOUTDIR)/$$size/* -type d`; do printf "$$dir,"; done; done; echo "scalable/actions,scalable/apps,scalable/categories,scalable/devices,scalable/emblems,scalable/emotes,scalable/mimetypes,scalable/places,scalable/status, scalable-up-to-32/status")
+THEME_DIRS=$(shell SIZES="$(render_sizes)"; for size in $$SIZES; do for dir in `find $(srcdir)/$(SVGOUTDIR)/$$size/* -type d`; do printf "$$dir,"; done; done; echo "scalable/actions,scalable/apps,scalable/categories,scalable/devices,scalable/emblems,scalable/emotes,scalable/mimetypes,scalable/places,scalable/status,scalable-up-to-32/status,")
%.theme.in: %.theme.in.in $(SVGOUTDIR) Makefile
dirs="`echo $(THEME_DIRS) | sed -e 's#$(srcdir)/Adwaita/##g'`"; \
@@ -64,14 +64,14 @@ THEME_DIRS=$(shell SIZES="$(render_sizes)"; for size in $$SIZES; do for dir in `
echo "MinSize=8" >> $@; \
echo "MaxSize=512" >> $@; \
echo "Type=Scalable" >> $@; \
+ elif test "$$sizefull" = "scalable-up-to-32"; then \
+ echo "MinSize=16" >> $@; \
+ echo "MaxSize=32" >> $@; \
+ echo "Type=Scalable" >> $@; \
elif test "$$size" = "256"; then \
echo "MinSize=56" >> $@; \
echo "MaxSize=512" >> $@; \
- elif test "$$size" = "scalable-up-to-32"; then \
- echo "MinSize=8" >> $@; \
- echo "MaxSize=32" >> $@; \
echo "Type=Scalable" >> $@; \
- echo "Type=Scalable" >> $@; \
else \
echo "Type=Fixed" >> $@; \
fi; \