summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJody Goldberg <jody@gnome.org>2004-01-13 03:34:12 +0000
committerJody Goldberg <jody@src.gnome.org>2004-01-13 03:34:12 +0000
commitbb136834231dafebdb5f1c497444fc327ab303f0 (patch)
tree0a6e033a9cabe3e83c93ab060f78865265864ab7 /Makefile.am
parent6943d8448b53640fa27db709f9a723ad7d592b70 (diff)
downloadadwaita-icon-theme-bb136834231dafebdb5f1c497444fc327ab303f0.tar.gz
Cause more problems. Put in an install time test that hicolor exists. It
2004-01-12 Jody Goldberg <jody@gnome.org> * Makefile.am (install-data-local) : Cause more problems. Put in an install time test that hicolor exists. It is not strictly correct. What we really need is a _package_ dependency. But it should at least light off a few warning bells.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7ff637040..7e5676aed 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,6 +7,11 @@ THEME_IN_FILES=index.theme.in
%.theme: %.theme.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
+hicolor_dirs = \
+ $(datadir)/pixmaps \
+ $(datadir)/icons \
+ /usr/share/icons \
+ /usr/share/pixmaps
icondir = $(datadir)/icons/gnome
icon_DATA = index.theme
@@ -18,5 +23,21 @@ EXTRA_DIST=index.theme.in index.theme intltool-update.in intltool-merge.in intlt
# we don't want to install mo files, all translations are already stored
# in theme files
+# Ensure that hicolor is installed too
install-data-local:
$(MAKE) -C po uninstall
+ @dirs='$(hicolor_dirs)'; for dir in $$dirs; do \
+ echo Checking for hicolor theme in \'$$dir/hicolor/index.theme\' ; \
+ if test -f "$$dir/hicolor/index.theme"; then \
+ echo Good. Found it. ; \
+ exit 0; \
+ fi ; \
+ done ; \
+ echo ; \
+ echo "@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@" ; \
+ echo "Could not find the theme 'hicolor' which acts as the base for all other" ; \
+ echo "themes, including gnome-icon-theme. Perhaps you need to install it." ; \
+ echo "You can get a copy from http://freedesktop.org/Software/icon-theme/releases" ; \
+ echo "@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@" ; \
+ echo ; \
+ exit 1