summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLapo Calamandrei <calamandrei@gmail.com>2010-05-24 18:08:20 +0200
committerLapo Calamandrei <calamandrei@gmail.com>2010-05-24 18:08:20 +0200
commitd5f441bb32b3af9e3e8eef9d46f9bd76a6f81b16 (patch)
tree280aa9fe783bc8ffd772ddc35bdafcb9044adccb /Makefile.am
parent9ac4035fc879ebd917a430ea2532a2bd702f1362 (diff)
downloadadwaita-icon-theme-d5f441bb32b3af9e3e8eef9d46f9bd76a6f81b16.tar.gz
Applied Matthias Clasen patch for adding scalable/ tree in index theme (needed for symbolic icons), see fixes #617292
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index cb080f702..0bec5b44d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,14 +5,18 @@ SUBDIRS = po $(SVGSRCDIR)
theme_in_files = index.theme.in.in
theme_DATA = $(theme_in_files:.theme.in.in=.theme)
-THEME_DIRS=$(shell SIZES="$(render_sizes)"; for size in $$SIZES; do for dir in `find $(srcdir)/$(SVGOUTDIR)/$$size/* -type d`; do printf "$$dir,"; done; done | sed -e "s/,$$//g")
+THEME_DIRS=$(shell SIZES="$(render_sizes)"; for size in $$SIZES; do for dir in `find $(srcdir)/$(SVGOUTDIR)/$$size/* -type d`; do printf "$$dir,"; done; done; echo "scalable/actions,scalable/apps,scalable/devices,scalable/emblems,scalable/mimetypes,scalable/places,scalable/status")
%.theme.in: %.theme.in.in $(SVGOUTDIR) Makefile
dirs="`echo $(THEME_DIRS) | sed -e 's#$(srcdir)/gnome/##g'`"; \
sed -e "s|\@THEME_DIRS\@|$$dirs|g" < $< > $@; \
for dir in `echo $$dirs | sed -e "s/,/ /g"`; do \
sizefull="`dirname $$dir`"; \
- size="`echo $$sizefull | sed -e 's/x.*$$//g'`"; \
+ if test "$$sizefull" = "scalable"; then \
+ size="16"; \
+ else \
+ size="`echo $$sizefull | sed -e 's/x.*$$//g'`"; \
+ fi; \
context="`basename $$dir`"; \
echo "[$$dir]" >> $@; \
if test "$$context" = "actions"; then \
@@ -49,7 +53,11 @@ THEME_DIRS=$(shell SIZES="$(render_sizes)"; for size in $$SIZES; do for dir in `
echo "Context=Status" >> $@; \
fi; \
echo "Size=$$size" >> $@; \
- if test "$$size" = "256"; then \
+ if test "$$sizefull" = "scalable"; then \
+ echo "MinSize=16" >> $@; \
+ echo "MaxSize=256" >> $@; \
+ echo "Type=Scalable" >> $@; \
+ elif test "$$size" = "256"; then \
echo "MinSize=56" >> $@; \
echo "MaxSize=512" >> $@; \
echo "Type=Scalable" >> $@; \