summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Steiner <jimmac@gmail.com>2018-12-13 16:28:36 +0100
committerJakub Steiner <jimmac@gmail.com>2018-12-13 16:41:23 +0100
commite5841d79f1f1356f5086e8a8f8b054d7d68f2586 (patch)
tree90329f5cccce4df17ce656f3d84b153cacd1693a /Makefile.am
parenteb8fef219c53ed29167306a8837c153625062bda (diff)
downloadadwaita-icon-theme-e5841d79f1f1356f5086e8a8f8b054d7d68f2586.tar.gz
add placeholder dirs to generate index.theme
- the sizes only get added to index.theme if a folder exists and this is done prior the odd symbolic png generation
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f3dc9ef77..0585021f0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,7 +29,7 @@ endif
theme_in_files = index.theme.in
theme_DATA = $(theme_in_files:.theme.in=.theme)
-THEME_DIRS=$(shell SIZES="$(install_sizes)"; for size in $$SIZES; do for dir in `find $(srcdir)/$(SVGOUTDIR)/$$size/* -type d`; do printf "$$dir,"; done; done; echo "scalable/actions,scalable/apps,scalable/categories,scalable/devices,scalable/emblems,scalable/emotes,scalable/mimetypes,scalable/places,scalable/status,scalable/legacy,scalable-up-to-32/status,")
+THEME_DIRS=$(shell SIZES="$(install_sizes)"; for size in $$SIZES; do for dir in `find $(srcdir)/$(SVGOUTDIR)/$$size/* -type d`; do printf "$$dir,"; done; done; echo "scalable/actions,scalable/apps,scalable/categories,scalable/devices,scalable/emblems,scalable/emotes,scalable/mimetypes,scalable/places,scalable/status,scalable/legacy,scalable/ui,scalable-up-to-32/status,")
%.theme: %.theme.in $(SVGOUTDIR) Makefile
dirs="`echo $(THEME_DIRS) | sed -e 's#$(srcdir)/Adwaita/##g'`"; \