summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDebarshi Ray <debarshir@gnome.org>2015-11-26 15:18:03 +0100
committerJakub Steiner <jimmac@gmail.com>2015-11-26 15:53:24 +0100
commitf7701a76ce7cdd57c49ed52594cd75ebed882660 (patch)
tree235a8705675d0e8bf8dd61514aff08f5473934f1 /Makefile.am
parent3b17d27c53a926b976002cf489261e6aaabb6458 (diff)
downloadadwaita-icon-theme-f7701a76ce7cdd57c49ed52594cd75ebed882660.tar.gz
Remove translations
Only the description is being translated and that's not exposed and "The Only One" is not really somethig worth sharing in the first place. https://bugzilla.gnome.org/show_bug.cgi?id=758708
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 5 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index 4d0026887..03148025e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
DISTCHECK_CONFIGURE_FLAGS = --disable-icon-mapping
-SUBDIRS = po src
+SUBDIRS = src
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
@@ -18,12 +18,12 @@ cursorxldir =
cursorxl_DATA =
endif
-theme_in_files = index.theme.in.in
-theme_DATA = $(theme_in_files:.theme.in.in=.theme)
+theme_in_files = index.theme.in
+theme_DATA = $(theme_in_files:.theme.in=.theme)
THEME_DIRS=$(shell SIZES="$(install_sizes)"; for size in $$SIZES; do for dir in `find $(srcdir)/$(SVGOUTDIR)/$$size/* -type d`; do printf "$$dir,"; done; done; echo "scalable/actions,scalable/apps,scalable/categories,scalable/devices,scalable/emblems,scalable/emotes,scalable/mimetypes,scalable/places,scalable/status,scalable-up-to-32/status,")
-%.theme.in: %.theme.in.in $(SVGOUTDIR) Makefile
+%.theme: %.theme.in $(SVGOUTDIR) Makefile
dirs="`echo $(THEME_DIRS) | sed -e 's#$(srcdir)/Adwaita/##g'`"; \
sed -e "s|\@THEME_DIRS\@|$$dirs|g" < $< > $@; \
for dir in `echo $$dirs | sed -e "s/,/ /g"`; do \
@@ -89,8 +89,6 @@ THEME_DIRS=$(shell SIZES="$(install_sizes)"; for size in $$SIZES; do for dir in
echo "" >> $@; \
done
-@INTLTOOL_THEME_RULE@
-
# Symbolic?
#THEME_DIRS=$(shell SIZES="$(render_sizes)"; for size in $$SIZES; do for dir in `find $(srcdir)/$(SVGOUTDIR)/$$size/* -type d`; do printf "$$dir,"; done; done | sed -e "s/,$$//g")
@@ -101,7 +99,6 @@ render: Makefile
# we don't want to install mo files, all translations are already stored
# in theme files
install-data-local:
- $(MAKE) -C po uninstall
if [ -h $(DESTDIR)$(themedir) ]; then \
rm -f $(DESTDIR)$(themedir); \
fi
@@ -225,9 +222,7 @@ MAINTAINERCLEANFILES = \
libtool \
ltmain.sh \
missing \
- mkinstalldirs \
- po/Makefile.in.in \
- po/$(GETTEXT_PACKAGE).pot
+ mkinstalldirs
-include $(top_srcdir)/git.mk