summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam Jon McCann <william.jon.mccann@gmail.com>2014-04-25 13:52:52 -0400
committerWilliam Jon McCann <william.jon.mccann@gmail.com>2014-04-25 14:02:47 -0400
commitf20c36b818afed352a344505748a2c97ec3dd7ce (patch)
tree4ef86b6404e4e01e78fa5d3f52899debd369ee76 /configure.ac
parentb6042e902cf4fe3fcbcb6c07aa0a94e88d2b238e (diff)
parent526e07c5d7c2ad16a1be2144553925d0720a7bba (diff)
downloadadwaita-icon-theme-f20c36b818afed352a344505748a2c97ec3dd7ce.tar.gz
Merge gnome-icon-theme-symbolic
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b9f759388..324f7b0c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,9 +24,11 @@ AC_SUBST(themedir, "\${datadir}/icons/Adwaita")
# Input and Output dirs for the rendering
AC_SUBST(SVGOUTDIR, "Adwaita")
+AC_SUBST(SVGSRCDIR, "src")
# Icon sizes we want to install
AC_SUBST([render_sizes], ["8x8 16x16 22x22 24x24 32x32 48x48 256x256"])
+AC_SUBST([symbolic_render_sizes], [""])
# Allow icon mapping to be disabled
AC_ARG_ENABLE([icon-mapping],
@@ -62,12 +64,29 @@ if test -z "$GTK_UPDATE_ICON_CACHE"; then
AC_MSG_ERROR([Could not find gtk-update-icon-cache])
fi
+# need git, icontool, and inkscape for rendering
+allow_rendering=yes
+AC_PATH_PROG([GIT], [git], [false])
+if test "x$GIT" = "xfalse"; then
+ allow_rendering=no
+fi
+AC_PATH_PROG([ICONTOOL_RENDER], [icontool-render], [false])
+if test "x$ICONTOOL_RENDER" = "xfalse"; then
+ allow_rendering=no
+fi
+AC_PATH_PROG([INKSCAPE], [inkscape], [false])
+if test "x$INKSCAPE" = "xfalse"; then
+ allow_rendering=no
+fi
+AM_CONDITIONAL(ALLOW_RENDERING, test "x$allow_rendering" = "xyes")
+
AC_CONFIG_FILES([
Makefile
adwaita-icon-theme.pc
po/Makefile.in
src/Makefile
src/fullcolor/Makefile
+src/symbolic/Makefile
])
AC_OUTPUT