summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2016-11-17 17:36:02 +0100
committerJakub Steiner <jimmac@gmail.com>2016-12-05 18:55:57 +0100
commitfa1a4b9181111c3e4d0111ee87f8b4288a1f1ecb (patch)
treea0b293efe28c144d914b118e5d7964a2c0af957d /configure.ac
parent4bd1d84ba07ccbfd6046c7194eb489b6a7ae1bfd (diff)
downloadadwaita-icon-theme-fa1a4b9181111c3e4d0111ee87f8b4288a1f1ecb.tar.gz
windows: Add Windows cursors and install them instead of X cursors on Windows
The new cursors where created using ./renderpngs.py -r -s -t -o -m 32 -a -c -i -n 4 adwaita.svg ./pngs/make-w32.sh Remove the --enable-w32-cursors switch and instead only install Windows cursors on Windows and X cursors everywhere else. This makes cursors work in the gtk3-demo "Cursors" demo and when dragging things.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 11 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 78a7f337b..d5fcfa6e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,6 +3,7 @@ AC_PREREQ(2.53)
AC_INIT([adwaita-icon-theme], [3.21.91],
[http://bugzilla.gnome.org/enter_bug.cgi?product=adwaita-icon-theme])
+AC_CANONICAL_HOST
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_SRCDIR([index.theme.in])
@@ -54,16 +55,16 @@ if test "x$GTK_ENCODE_SYMBOLIC_SVG" = "xfalse"; then
fi
AC_SUBST(symbolic_encode_sizes)
-AC_ARG_ENABLE([w32-cursors],
- [AS_HELP_STRING([--enable-w32-cursors],
- [Make and install Windows cursors (.cur and .ani) instead of X cursors])],
- [case "${enableval}" in
- yes) enable_w32_cursors=yes ;;
- no) enable_w32_cursors=no ;;
- *) AC_MSG_ERROR([bad value ${enableval} for --enable-w32-cursors]) ;;
- esac],
- [enable_w32_cursors=no])
-AC_SUBST(enable_w32_cursors)
+case "$host" in
+ *-*-mingw*|*-*-cygwin*)
+ platform_win32=yes
+ ;;
+ *)
+ platform_win32=no
+ ;;
+esac
+AC_SUBST(platform_win32)
+AM_CONDITIONAL([PLATFORM_WIN32], [test x$platform_win32 = xyes])
AC_ARG_ENABLE([l-xl-variants],
[AS_HELP_STRING([--enable-l-xl-variants],