summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWilliam Jon McCann <william.jon.mccann@gmail.com>2014-04-25 13:16:47 -0400
committerWilliam Jon McCann <william.jon.mccann@gmail.com>2014-04-25 13:16:47 -0400
commit526e07c5d7c2ad16a1be2144553925d0720a7bba (patch)
tree7d2ea2a5e026a010e5ab833bc8caabc91c6c8d32 /src/Makefile.am
parentf7f1407e9b970bc3d94d6e7335da97f03af4c839 (diff)
downloadadwaita-icon-theme-526e07c5d7c2ad16a1be2144553925d0720a7bba.tar.gz
Move src to subdir
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am56
1 files changed, 0 insertions, 56 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
deleted file mode 100644
index 254a67e1b..000000000
--- a/src/Makefile.am
+++ /dev/null
@@ -1,56 +0,0 @@
-
-icon_in_files = $(shell SRCDIR="$(srcdir)"; for i in `find $$SRCDIR -name "*.svg"`; do printf "$$i "; done)
-
-if ALLOW_RENDERING
-render-png: $(icon_in_files) Makefile
- for file in $(icon_in_files); do \
- for size in $(render_sizes); do \
- $(ICONTOOL_RENDER) -s $$size -o $(top_builddir)/$(SVGOUTDIR) $$file >/dev/null; \
- done; \
- done
-
-else
-render-png: $(icon_in_files) Makefile
- if test "x$(top_srcdir)" != "x$(top_builddir)"; then \
- cp -a $(top_srcdir)/$(SVGOUTDIR) $(top_builddir)/$(SVGOUTDIR); \
- fi
-
-endif
-
-$(render_sizes): Makefile
-
-render: render-png
-
-all-local: render
-
-install-data-local:
- for size in $(render_sizes); do \
- for file in `cd $(top_builddir)/$(SVGOUTDIR)/$$size; find . -name "*.png"`; do \
- context="`dirname $$file`"; \
- $(mkdir_p) $(DESTDIR)$(themedir)/$$size/$$context; \
- $(install_sh_DATA) $(top_srcdir)/$(SVGOUTDIR)/$$size/$$file $(DESTDIR)$(themedir)/$$size/$$file; \
- done; \
- done
- for file in `cd $(top_builddir)/$(SVGOUTDIR)/scalable; find . -name "*.svg"`; do \
- context="`dirname $$file`"; \
- $(mkdir_p) $(DESTDIR)$(themedir)/scalable/$$context; \
- $(install_sh_DATA) $(top_srcdir)/$(SVGOUTDIR)/scalable/$$file $(DESTDIR)$(themedir)/scalable/$$file; \
- done
-
-uninstall-local:
- for size in $(render_sizes); do \
- for file in `cd $(top_builddir)/$(SVGOUTDIR)/$$size; find . -name "*.png"`; do \
- rm -f $(DESTDIR)$(themedir)/$$size/$$file; \
- done; \
- done
-
-EXTRA_DIST = \
- $(icon_in_files)
-
-
-MAINTAINERCLEANFILES = \
- *~ \
- Makefile.in \
- $(icon_cache)
-
--include $(top_srcdir)/git.mk