summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0c5a3c6e9..6e7bb1dc5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -81,7 +81,9 @@ install-data-local:
fi
install-data-hook:
- $(GTK_UPDATE_ICON_CACHE) -q $(DESTDIR)$(themedir)
+ if test -z "$(DESTDIR)" ; then \
+ $(GTK_UPDATE_ICON_CACHE) -q $(DESTDIR)$(themedir); \
+ fi
uninstall-hook:
@rm -f $(DESTDIR)$(themedir)/icon-theme.cache