summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am94
1 files changed, 89 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index a7a47676f..fd5b438ad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,8 +1,78 @@
DISTCHECK_CONFIGURE_FLAGS = --disable-icon-mapping
-SUBDIRS = $(SVGSRCDIR)
+SUBDIRS = po src
-THEME_DIRS=$(shell SIZES="$(render_sizes)"; for size in $$SIZES; do for dir in `find $(srcdir)/$(SVGOUTDIR)/$$size/* -type d`; do printf "$$dir,"; done; done | sed -e "s/,$$//g")
+ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
+
+theme_in_files = index.theme.in.in
+theme_DATA = $(theme_in_files:.theme.in.in=.theme)
+
+THEME_DIRS=$(shell SIZES="$(render_sizes)"; for size in $$SIZES; do for dir in `find $(srcdir)/$(SVGOUTDIR)/$$size/* -type d`; do printf "$$dir,"; done; done; echo "scalable/actions,scalable/apps,scalable/devices,scalable/emblems,scalable/mimetypes,scalable/places,scalable/status,scalable/categories")
+
+%.theme.in: %.theme.in.in $(SVGOUTDIR) Makefile
+ dirs="`echo $(THEME_DIRS) | sed -e 's#$(srcdir)/Adwaita/##g'`"; \
+ sed -e "s|\@THEME_DIRS\@|$$dirs|g" < $< > $@; \
+ for dir in `echo $$dirs | sed -e "s/,/ /g"`; do \
+ sizefull="`dirname $$dir`"; \
+ if test "$$sizefull" = "scalable"; then \
+ size="16"; \
+ else \
+ size="`echo $$sizefull | sed -e 's/x.*$$//g'`"; \
+ fi; \
+ context="`basename $$dir`"; \
+ echo "[$$dir]" >> $@; \
+ if test "$$context" = "actions"; then \
+ echo "Context=Actions" >> $@; \
+ fi; \
+ if test "$$context" = "animations"; then \
+ echo "Context=Animations" >> $@; \
+ fi; \
+ if test "$$context" = "apps"; then \
+ echo "Context=Applications" >> $@; \
+ fi; \
+ if test "$$context" = "categories"; then \
+ echo "Context=Categories" >> $@; \
+ fi; \
+ if test "$$context" = "devices"; then \
+ echo "Context=Devices" >> $@; \
+ fi; \
+ if test "$$context" = "emblems"; then \
+ echo "Context=Emblems" >> $@; \
+ fi; \
+ if test "$$context" = "emotes"; then \
+ echo "Context=Emotes" >> $@; \
+ fi; \
+ if test "$$context" = "intl"; then \
+ echo "Context=International" >> $@; \
+ fi; \
+ if test "$$context" = "mimetypes"; then \
+ echo "Context=MimeTypes" >> $@; \
+ fi; \
+ if test "$$context" = "places"; then \
+ echo "Context=Places" >> $@; \
+ fi; \
+ if test "$$context" = "status"; then \
+ echo "Context=Status" >> $@; \
+ fi; \
+ echo "Size=$$size" >> $@; \
+ if test "$$sizefull" = "scalable"; then \
+ echo "MinSize=8" >> $@; \
+ echo "MaxSize=512" >> $@; \
+ echo "Type=Scalable" >> $@; \
+ elif test "$$size" = "256"; then \
+ echo "MinSize=56" >> $@; \
+ echo "MaxSize=512" >> $@; \
+ echo "Type=Scalable" >> $@; \
+ else \
+ echo "Type=Fixed" >> $@; \
+ fi; \
+ echo "" >> $@; \
+ done
+
+@INTLTOOL_THEME_RULE@
+
+# Symbolic?
+#THEME_DIRS=$(shell SIZES="$(render_sizes)"; for size in $$SIZES; do for dir in `find $(srcdir)/$(SVGOUTDIR)/$$size/* -type d`; do printf "$$dir,"; done; done | sed -e "s/,$$//g")
render: Makefile
($(am__cd) $(SVGSRCDIR) && $(MAKE) $(AM_MAKEFLAGS) render) \
@@ -11,6 +81,7 @@ render: Makefile
# we don't want to install mo files, all translations are already stored
# in theme files
install-data-local:
+ $(MAKE) -C po uninstall
if [ -h $(DESTDIR)$(themedir) ]; then \
rm -f $(DESTDIR)$(themedir); \
fi
@@ -23,10 +94,21 @@ install-data-hook:
$(GTK_UPDATE_ICON_CACHE) -q $(DESTDIR)$(themedir); \
fi
+uninstall-hook:
+ @rm -f $(DESTDIR)$(themedir)/icon-theme.cache
+
pkgconfigdir = $(datadir)/pkgconfig
-pkgconfig_DATA = gnome-icon-theme-symbolic.pc
+pkgconfig_DATA = adwaita-icon-theme.pc
+
+EXTRA_DIST = \
+ adwaita-icon-theme.pc.in \
+ Adwaita \
+ COPYING_CCBYSA3 \
+ COPYING_LGPL \
+ $(theme_in_files)
-EXTRA_DIST = gnome-icon-theme-symbolic.pc.in gnome
+CLEANFILES = \
+ $(theme_DATA)
MAINTAINERCLEANFILES = \
Makefile.in \
@@ -41,6 +123,8 @@ MAINTAINERCLEANFILES = \
libtool \
ltmain.sh \
missing \
- mkinstalldirs
+ mkinstalldirs \
+ po/Makefile.in.in \
+ po/$(GETTEXT_PACKAGE).pot
-include $(top_srcdir)/git.mk