summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDamien Lespiau <damien.lespiau@intel.com>2011-03-25 08:54:00 +0000
committerDamien Lespiau <damien.lespiau@intel.com>2011-03-25 08:54:00 +0000
commite1773eb680d1f82dbd20f80bc5912ced6a4a72d1 (patch)
tree02d4938f5a537a036927c45f8b297a74ab61c4d9 /Makefile.am
parent2af35fa2f6f9e826b27829802a4647000959449c (diff)
downloadclutter-gst-e1773eb680d1f82dbd20f80bc5912ced6a4a72d1.tar.gz
build: Take into account ACLOCAL_FLAGS during autoreconf
ACLOCAL_FLAGS is a semi-standard way to add flags to aclocal during the autoreconf pass. This is used by GNOME quite heavily and it's really useful when rebuilding/unzipping every dependency in a separate prefix on Windows as the msys base system will have the bare miminum in /usr/share/aclocal (even pkg.m4 has chances to be in a separate prefix). eg. ACLOCAL_FLAGS="-I /home/damien/clutter/install/share/aclocal" allows me to install all the deps in ~/clutter/install and have autoreconf pick up the macros there.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 64c48c3..e448d88 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,7 +8,7 @@ endif
DIST_SUBDIRS = build scripts clutter-gst tests examples doc
-ACLOCAL_AMFLAGS = -I build/autotools
+ACLOCAL_AMFLAGS = -I build/autotools ${ACLOCAL_FLAGS}
clutter-gst-$(CLUTTER_GST_API_VERSION).pc: clutter-gst.pc
$(QUIET_GEN)cp -f clutter-gst.pc $@