summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndre Moreira Magalhaes (andrunko) <andre.magalhaes@collabora.co.uk>2012-08-15 15:36:13 -0300
committerLionel Landwerlin <llandwerlin@gmail.com>2013-03-18 16:24:19 +0000
commit24afea38b0254c91d83abac09df334c3e8a1884e (patch)
treef33d0c2f145de8874c75b8dc110468a1eb6990dd /configure.ac
parent228b9f33dffcfebcf988fb9c61442a792eca3756 (diff)
downloadclutter-gst-24afea38b0254c91d83abac09df334c3e8a1884e.tar.gz
ClutterGstCameraActor: Add new actor for camera streams.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1b38725..690f8b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -152,6 +152,7 @@ PKG_CHECK_MODULES(GST,
[gstreamer-$GST_MAJORMINOR >= $GSTREAMER_REQ_VERSION
gstreamer-plugins-base-$GST_MAJORMINOR
gstreamer-base-$GST_MAJORMINOR
+ gstreamer-pbutils-$GST_MAJORMINOR
gstreamer-video-$GST_MAJORMINOR
gstreamer-audio-$GST_MAJORMINOR
gstreamer-tag-$GST_MAJORMINOR])
@@ -207,6 +208,14 @@ AS_IF([test "x$have_cogl_osx" = xyes],
AC_SUBST([GL_LDFLAGS])
])
+PKG_CHECK_MODULES(GUDEV,
+ [gudev-1.0],
+ [
+ have_gudev=yes
+ AC_DEFINE([HAVE_GUDEV], [1],
+ ["Defined if gudev is available"])
+ ],[ have_gudev=no ])
+
dnl ========================================================================
dnl Experimental support for hardware accelerated decoders.
dnl Temporarily disabling for GStreamer 1.0 since it's causing too many issues
@@ -324,4 +333,5 @@ echo " • Extra:"
echo " API documentation : ${enable_gtk_doc}"
echo " Introspection data: ${enable_introspection}"
echo " HW Decoder support: ${have_hw_decoder_support}"
+echo " UDEV support : ${have_gudev}"
echo ""