summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Lespiau <damien.lespiau@intel.com>2011-03-25 10:40:30 +0000
committerDamien Lespiau <damien.lespiau@intel.com>2011-03-25 11:12:37 +0000
commit421940fcb9a14873dbb4d1ffd2dcd860ff0b2e81 (patch)
tree86db52106c8b988fec9242d570375a7e80d5026b /configure.ac
parentd64989596c0dd7e3ba3ea7ea79a1f5cf8c541892 (diff)
downloadclutter-gst-421940fcb9a14873dbb4d1ffd2dcd860ff0b2e81.tar.gz
build: Generate DLLs on Windows
You need to give -no-undefined to libtool to generate DLLs under Windows. Fixes: http://bugzilla.clutter-project.org/show_bug.cgi?id=2603
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 967d8e4..1e88716 100644
--- a/configure.ac
+++ b/configure.ac
@@ -53,6 +53,19 @@ CLUTTER_GST_LT_AGE=lt_age
CLUTTER_GST_LT_VERSION="$CLUTTER_GST_LT_CURRENT:$CLUTTER_GST_LT_REV:$CLUTTER_GST_LT_AGE"
CLUTTER_GST_LT_LDFLAGS="-version-info $CLUTTER_GST_LT_VERSION"
+AC_CANONICAL_HOST
+AC_MSG_CHECKING([if building for some Win32 platform])
+AS_CASE([$host],
+ [*-*-mingw*|*-*-cygwin*],
+ [
+ CLUTTER_GST_LT_LDFLAGS="$CLUTTER_GST_LT_LDFLAGS -no-undefined"
+ platform_win32=yes
+ ],
+
+ [platform_win32=no]
+)
+AC_MSG_RESULT([$platform_win32])
+
AC_SUBST(CLUTTER_GST_LT_VERSION)
AC_SUBST(CLUTTER_GST_LT_LDFLAGS)