summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLionel Landwerlin <llandwerlin@gmail.com>2014-06-26 22:22:22 +0100
committerLionel Landwerlin <llandwerlin@gmail.com>2014-06-26 22:22:22 +0100
commit6c78b27a0458240988bc2e5b52644c7052064f36 (patch)
tree69a5730ba558d05cc152c7a342fe1e30cfdafb07 /configure.ac
parentb7eb4d54e863a96e231d11668d5e84613bba3f8a (diff)
downloadclutter-gst-6c78b27a0458240988bc2e5b52644c7052064f36.tar.gz
configure.ac: add opportunity to disable gl texture upload support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 14 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index b79515b..e05f9d2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -221,14 +221,19 @@ dnl ========================================================================
dnl Experimental support for hardware accelerated decoders.
dnl Temporarily disabling for GStreamer 1.0 since it's causing too many issues
dnl and the API for hw support isn't yet put in stone
-have_hw_decoder_support=no
-# PKG_CHECK_MODULES(HW,
-# [gstreamer-basevideo-$GST_MAJORMINOR >= $GST_PLUGINS_BAD_REQ_VERSION],
-# [
-# have_hw_decoder_support=yes
-# AC_DEFINE([HAVE_HW_DECODER_SUPPORT], [1],
-# ["Defined if building Clutter with HW decoder support"])
-# ],[ have_hw_decoder_support=no ])
+m4_define([texture_upload_default], yes)
+AC_ARG_ENABLE([gl-texture-upload],
+ [AC_HELP_STRING([--enable-gl-texture-upload=@<:@no/yes@:>@],
+ [Enable GL texture upload support @<:@default=]texture_upload_default[@:>@])],
+ [],
+ enable_gl_texture_upload=texture_upload_default)
+
+AS_IF([test "x$enable_gl_texture_upload" = "xyes"],
+ [
+ AC_DEFINE([HAVE_GL_TEXTURE_UPLOAD], [1],
+ ["GL texture upload support"])
+ ]
+)
dnl ========================================================================
@@ -332,6 +337,6 @@ echo ""
echo " • Extra:"
echo " API documentation : ${enable_gtk_doc}"
echo " Introspection data: ${enable_introspection}"
-echo " HW Decoder support: ${have_hw_decoder_support}"
+echo " GL texture upload : ${enable_gl_texture_upload}"
echo " UDEV support : ${have_gudev}"
echo ""