summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorMatthew Allum <mallum@openedhand.com>2007-04-26 15:52:54 +0000
committerMatthew Allum <mallum@openedhand.com>2007-04-26 15:52:54 +0000
commit4a8a8c273ab5682f452d538e3a1afe8eaf7e9b09 (patch)
treecb1fe14938273619f2757ed47e3cf25f151ffc6d /examples/Makefile.am
parent66c28769b1cf6e952745f4915203e34890f369ae (diff)
downloadclutter-gst-4a8a8c273ab5682f452d538e3a1afe8eaf7e9b09.tar.gz
2007-04-26 Matthew Allum <mallum@openedhand.com>
* clutter-gst/Makefile.am: * clutter-gst/clutter-gst-util.c: * clutter-gst/clutter-gst-util.h: * clutter-gst/clutter-gst.h: Add a clutter_gst_init() call mainly for binding usage. * clutter-gst/clutter-gst-video-sink.c: * clutter-gst/clutter-gst-video-sink.h: * clutter-gst/clutter-gst-video-texture.c: * examples/Makefile.am: * examples/README: * examples/video-sink.c: Addition of clutter texture gstreamer video sink from Jonathan Matthew (#296)
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 6afbf65..1a4649b 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -1,4 +1,4 @@
-noinst_PROGRAMS = video-player video-cube audio
+noinst_PROGRAMS = video-player video-cube video-sink audio
INCLUDES = -I$(top_srcdir)/
@@ -16,6 +16,13 @@ video_cube_LDFLAGS = \
$(GST_LIBS) \
$(top_builddir)/clutter-gst/libclutter-gst-@CLUTTER_GST_MAJORMINOR@.la
+video_sink_SOURCES = video-sink.c
+video_sink_CFLAGS = $(CLUTTER_GST_CFLAGS) $(GST_CFLAGS)
+video_sink_LDFLAGS = \
+ $(CLUTTER_GST_LIBS) \
+ $(GST_LIBS) \
+ $(top_builddir)/clutter-gst/libclutter-gst-@CLUTTER_GST_MAJORMINOR@.la
+
audio_SOURCES = audio.c
audio_CFLAGS = $(CLUTTER_GST_CFLAGS) $(GST_CFLAGS)
audio_LDFLAGS = \