summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 18 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 94d8112..e0e33b0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,6 +2,10 @@ include $(top_srcdir)/build/autotools/Makefile.am.silent
ACLOCAL_AMFLAGS = -I build/autotools
+EXTRA_DIST =
+CLEANFILES =
+DISTCLEANFILES =
+
SUBDIRS = build clutter-gtk doc examples po
clutter-gtk-1.0.pc: clutter-gtk.pc
@@ -9,10 +13,21 @@ clutter-gtk-1.0.pc: clutter-gtk.pc
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = clutter-gtk-1.0.pc
+EXTRA_DIST += clutter-gtk.pc.in
+CLEANFILES += clutter-gtk-1.0.pc
+DISTCLEANFILES += clutter-gtk.pc
-EXTRA_DIST = clutter-gtk.pc.in
-CLEANFILES = clutter-gtk-1.0.pc
-DISTCLEANFILES = clutter-gtk.pc
+meson_build_data = \
+ meson.build \
+ meson_options.txt \
+ clutter-gtk/meson.build \
+ doc/meson.build \
+ doc/xml/meson.build \
+ doc/xml/gtkdocentities.ent.in \
+ examples/meson.build \
+ po/meson.build \
+ $()
+EXTRA_DIST += $(meson_build_data)
DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-maintainer-flags