summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@linux.intel.com>2010-01-04 14:53:03 +0000
committerEmmanuele Bassi <ebassi@linux.intel.com>2010-01-13 17:15:06 +0000
commit948db40c875f8eb7032582a32515737be6587067 (patch)
treeaabcb441cc6a21466f69e521eb7c0c326fcf921c /Makefile.am
parent5322546a4e2100bcec8aba651f8de7d849d67711 (diff)
downloadclutter-948db40c875f8eb7032582a32515737be6587067.tar.gz
Add gcov support to the build
Using gcov it's possible to get a coverage report, that is a break down of how much the exposed API is exercised by the conformance test suite.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f003afeb1..fc7ef37d3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -48,3 +48,6 @@ MAINTAINERCLEANFILES = \
$(NULL)
include $(top_srcdir)/build/autotools/Makefile.am.changelog
+
+gcov:
+ @( cd clutter && $(MAKE) $(AM_MAKEFLAGS) $@ ) || exit $$?