summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2018-06-17 19:19:28 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2018-06-17 19:19:28 +0100
commite0fe839dcf4b320897fee95ab5f111cd488c87ba (patch)
treef57f4a6a4ad4e001ceab5771bc899e3d7bbd01cf /Makefile.am
parent9d616b6773a106c886ba0c289b710b3bd00b5d3f (diff)
downloadclutter-e0fe839dcf4b320897fee95ab5f111cd488c87ba.tar.gz
build: Add the Meson files to the Autotools dist
We should allow to build Clutter with Meson even when using dist tarballs generated by Autotools.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e8516c92f..fa2d14a48 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,6 +22,29 @@ EXTRA_DIST = \
NEWS \
$(NULL)
+# Add the Meson build files to the Autotools dist
+meson_files = \
+ meson.build \
+ meson_options.txt \
+ clutter/meson.build \
+ clutter/cex100/meson.build \
+ doc/meson.build \
+ doc/cookbook/meson.build \
+ doc/reference/meson.build \
+ doc/reference/xml/gtkdocentities.ent.in \
+ doc/reference/xml/meson.build \
+ examples/meson.build \
+ po/meson.build \
+ tests/meson.build \
+ tests/interactive/meson.build \
+ tests/micro-bench/meson.build \
+ tests/conform/meson.build \
+ tests/accessibility/meson.build \
+ tests/performance/meson.build \
+ $()
+
+EXTRA_DIST += $(meson_files)
+
CLEANFILES = $(pcfiles)
DISTCLEANFILES =