summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@openedhand.com>2007-07-26 10:00:09 +0000
committerEmmanuele Bassi <ebassi@openedhand.com>2007-07-26 10:00:09 +0000
commite77a6f0af3fa26fb1b57cd2455188a47d8eb3156 (patch)
tree2e8562bfd03f54e482676699aaf4dc2722e797ab /Makefile.am
parent73ff6900d0e1d914d858c8ff5d6e3096c85f76a5 (diff)
downloadclutter-e77a6f0af3fa26fb1b57cd2455188a47d8eb3156.tar.gz
Enable strict compiler flags with a configure flag
When making a distcheck it's usually a good idea to enable very strict compiler flags, like -Werror, to catch stuff that slipped through the development phase. This patch adds a --enable-maintainer-flags command line switch to the configure script, which enables a set of strict compiler flags. The default is not to use them unless explicitly activated. In case of distcheck, this switch is activated when launching the configure script from within the distcheck build directory.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index bb2bc72eb..719561c83 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS=clutter doc tests
+SUBDIRS = clutter doc tests
pcfiles = clutter-@CLUTTER_FLAVOUR@-@CLUTTER_MAJORMINOR@.pc
@@ -8,7 +8,7 @@ pcfiles = clutter-@CLUTTER_FLAVOUR@-@CLUTTER_MAJORMINOR@.pc
pkgconfig_DATA = $(pcfiles)
pkgconfigdir = $(libdir)/pkgconfig
-DEFAULT_FLAVOUR=@CLUTTER_FLAVOUR@
+DEFAULT_FLAVOUR = @CLUTTER_FLAVOUR@
install-data-hook:
(cd $(DESTDIR)$(pkgconfigdir) && \
test -f clutter-$(DEFAULT_FLAVOUR)-@CLUTTER_MAJORMINOR@.pc && \
@@ -22,7 +22,7 @@ EXTRA_DIST = clutter.pc.in HACKING
CLEANFILES = $(pcfiles)
-DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
+DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-maintainer-flags
# Extra clean files so that maintainer-clean removes *everything*
MAINTAINERCLEANFILES = aclocal.m4 compile config.guess config.sub \