summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2015-12-08 17:20:13 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2015-12-08 17:20:13 +0000
commit7fe12eca54c15e9f2de0f87e7310afeb52ac8304 (patch)
treedb470442d571f1a0ced9c16382549fce87bbd168 /configure.ac
parentdd305950848891b5b91673033af134d3e1728cc3 (diff)
downloadclutter-7fe12eca54c15e9f2de0f87e7310afeb52ac8304.tar.gz
build: Use the 'x11' pkg-config module to check for X11
Don't look at GLX headers or symbols; we don't use them anyway. https://bugzilla.gnome.org/show_bug.cgi?id=759191
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index a6fc6cd98..985dc1b83 100644
--- a/configure.ac
+++ b/configure.ac
@@ -113,9 +113,6 @@ AM_CONDITIONAL(OS_WIN32, [test "$platform_win32" = "yes"])
AC_CHECK_HEADER([OpenGL/gl.h], [platform_quartz=yes], [platform_quartz=no])
AM_CONDITIONAL(OS_QUARTZ, [test "$platform_quartz" = "yes"])
-AC_CHECK_HEADER([GL/glx.h], [platform_glx=yes], [platform_glx=no])
-AC_CHECK_LIB([GL], [glXCreateContext], [platform_glx=yes], [platform_glx=no])
-AM_CONDITIONAL(OS_GLX, [test "$platform_glx" = "yes"])
AM_CONDITIONAL(OS_LINUX, [test "$platform_linux" = "yes"])
AC_SUBST(CLUTTER_LT_LDFLAGS)
@@ -285,7 +282,7 @@ AC_ARG_ENABLE([cex100-backend],
dnl Define default values
AS_IF([test "x$enable_x11" = "xcheck"],
[
- AS_IF([test "x$platform_glx" = "xyes"], [enable_x11=yes], [enable_x11=no])
+ PKG_CHECK_EXISTS([x11], [enable_x11=yes], [enable_x11=no])
])
AS_IF([test "x$enable_win32" = "xcheck"],