summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2015-12-09 14:26:28 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2015-12-10 16:38:46 +0000
commitbb23335b5fd29fb1d63e99b8f9eb32c5f11b4405 (patch)
treee7a95bf82888da81c7f2ec735c71465b30e5e11c /configure.ac
parent2c524fbf73cf5348cc1b03cced4a6b1c4c2f0224 (diff)
downloadclutter-bb23335b5fd29fb1d63e99b8f9eb32c5f11b4405.tar.gz
Add a configuration option for deciding the Cogl drivers to use
Using environment variables only is not convenient for all platforms, and in some cases it's beneficial to decide the default driver when building Clutter. Cogl already has a similar configuration switch, and since Clutter is overriding the default Cogl behaviour, it should offer the same mechanism. https://bugzilla.gnome.org/show_bug.cgi?id=742678
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 985dc1b83..e32f5dd71 100644
--- a/configure.ac
+++ b/configure.ac
@@ -585,6 +585,13 @@ dnl other tools such as glib-mkenums and gir-scanner don't end up
dnl using the define also.
AC_DEFINE([COGL_ENABLE_EXPERIMENTAL_2_0_API], [1], [Can use Cogl 2.0 API internally])
+AC_ARG_WITH([default-drivers],
+ [AS_HELP_STRING([--with-default-drivers=DRIVER], [Comma-separated list of Cogl drivers to use])],
+ [clutter_drivers=$withval],
+ [clutter_drivers="*"])
+
+AC_DEFINE_UNQUOTED([CLUTTER_DRIVERS], ["$clutter_drivers"], [List of Cogl drivers])
+
dnl strip leading spaces
CLUTTER_BACKENDS=${CLUTTER_BACKENDS#* }
AC_SUBST(CLUTTER_BACKENDS)
@@ -1285,6 +1292,8 @@ else
echo " Input backends: ${CLUTTER_INPUT_BACKENDS} (WARNING: Experimental backends enabled)"
fi
+echo " Cogl drivers: $clutter_drivers"
+
if test "x$SUPPORT_X11" = "x1"; then
echo ""
echo " - X11 backend options:"