summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJonas Ådahl <jadahl@gmail.com>2013-12-15 17:38:56 +0100
committerRui Matos <tiagomatos@gmail.com>2014-02-27 09:57:29 +0100
commitdacb515e27fe9f98fcfe7b93730e8b9bf76f11e2 (patch)
tree47c82b5d1b12036d13febd14bd1cbe26b8cf4c3c /configure.ac
parent488639eb63f0c26d65db0700e94b1067da873617 (diff)
downloadclutter-dacb515e27fe9f98fcfe7b93730e8b9bf76f11e2.tar.gz
evdev: Port evdev input backend to libinput
Instead of having its own evdev input device processing implementation, make clutter's evdev backend use libinput to do input device processing for it. Two GObject parameters of ClutterInputDeviceEvdev (sysfs-path and device-path) are removed as they are not used any more. Before ClutterDeviceManagerEvdev had one virtual core keyboard and one virtual core pointer device. These are now instead separated into seats, which all have one virtual core keyboard and pointer device respectively. The 'global' core keyboard and pointer device are the core keyboard and pointer device of the first seat that is created. A ClutterInputDeviceEvdev can, as before, both represent a real physical device or a virtual device, but is now instead created either via _clutter_input_device_evdev_new() for real devices, and _clutter_input_device_new_virtual() for virtual devices. XKB state and button state is moved to the seat structure and is thus separated per seat. Seats are not a concept exposed outside of clutter's evdev backend. Signed-off-by: Jonas Ådahl <jadahl@gmail.com> https://bugzilla.gnome.org/show_bug.cgi?id=720566
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index cbb433888..8cda44697 100644
--- a/configure.ac
+++ b/configure.ac
@@ -146,7 +146,8 @@ m4_define([uprof_req_version], [0.3])
m4_define([gtk_doc_req_version], [1.15])
m4_define([xcomposite_req_version], [0.4])
m4_define([gdk_req_version], [3.3.18])
-m4_define([libevdev_req_version], [0.4])
+m4_define([libinput_req_version], [0.0.90])
+m4_define([libudev_req_version], [136])
AC_SUBST([GLIB_REQ_VERSION], [glib_req_version])
AC_SUBST([COGL_REQ_VERSION], [cogl_req_version])
@@ -159,7 +160,8 @@ AC_SUBST([UPROF_REQ_VERSION], [uprof_req_version])
AC_SUBST([GTK_DOC_REQ_VERSION], [gtk_doc_req_version])
AC_SUBST([XCOMPOSITE_REQ_VERSION], [xcomposite_req_version])
AC_SUBST([GDK_REQ_VERSION], [gdk_req_version])
-AC_SUBST([LIBEVDEV_REQ_VERSION], [libevdev_req_version])
+AC_SUBST([LIBINPUT_REQ_VERSION], [libinput_req_version])
+AC_SUBST([LIBUDEV_REQ_VERSION], [libudev_req_version])
# Checks for typedefs, structures, and compiler characteristics.
AM_PATH_GLIB_2_0([glib_req_version],
@@ -474,7 +476,7 @@ AS_IF([test "x$enable_evdev" = "xyes"],
AS_IF([test "x$have_evdev" = "xyes"],
[
CLUTTER_INPUT_BACKENDS="$CLUTTER_INPUT_BACKENDS evdev"
- BACKEND_PC_FILES="$BACKEND_PC_FILES gudev-1.0 libevdev >= $LIBEVDEV_REQ_VERSION xkbcommon"
+ BACKEND_PC_FILES_PRIVATE="$BACKEND_PC_FILES_PRIVATE libudev >= $LIBUDEV_REQ_VERSION libinput >= $LIBINPUT_REQ_VERSION xkbcommon"
experimental_input_backend="yes"
AC_DEFINE([HAVE_EVDEV], [1], [Have evdev support for input handling])
SUPPORT_EVDEV=1