summaryrefslogtreecommitdiff
path: root/doc/reference/clutter/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/reference/clutter/Makefile.am')
-rw-r--r--doc/reference/clutter/Makefile.am68
1 files changed, 16 insertions, 52 deletions
diff --git a/doc/reference/clutter/Makefile.am b/doc/reference/clutter/Makefile.am
index 9fc9f47e6..df25a598f 100644
--- a/doc/reference/clutter/Makefile.am
+++ b/doc/reference/clutter/Makefile.am
@@ -1,39 +1,25 @@
DOC_MODULE = clutter
DOC_MAIN_SGML_FILE = $(DOC_MODULE)-docs.xml
-
-# The directory containing the source code. Relative to $(srcdir).
-# gtk-doc will search all .c & .h files beneath here for inline comments
-# documenting the functions and macros.
-# e.g. DOC_SOURCE_DIR=../../../gtk
DOC_SOURCE_DIR = $(top_srcdir)/clutter $(top_builddir)/clutter
-# Extra options to pass to gtkdoc-scangobj. Not normally needed.
-SCANGOBJ_OPTIONS = --type-init-func="clutter_base_init()"
-
-# Extra options to supply to gtkdoc-scan.
-# e.g. SCAN_OPTIONS=--deprecated-guards="GTK_DISABLE_DEPRECATED"
+SCANGOBJ_OPTIONS =
SCAN_OPTIONS =
-
-# Extra options to supply to gtkdoc-mkdb.
-# e.g. MKDB_OPTIONS=--sgml-mode --output-format=xml
-MKDB_OPTIONS = --output-format=xml --name-space=clutter
-
-# Extra options to supply to gtkdoc-mktmpl
-# e.g. MKTMPL_OPTIONS=--only-section-tmpl
+MKDB_OPTIONS = --xml-mode --output-format=xml --name-space=clutter
MKTMPL_OPTIONS =
-
-# Extra options to supply to gtkdoc-fixref. Not normally needed.
-# e.g. FIXXREF_OPTIONS=--extra-dir=../gdk-pixbuf/html --extra-dir=../gdk/html
FIXXREF_OPTIONS = \
--extra-dir=$(GLIB_PREFIX)/share/gtk-doc/html/glib \
--extra-dir=$(GLIB_PREFIX)/share/gtk-doc/html/gobject \
--extra-dir=$(CAIRO_PREFIX)/share/gtk-doc/html/cairo \
--extra-dir=$(PANGO_PREFIX)/share/gtk-doc/html/pango \
- --extra-dir=$(COGL_PREFIX)/share/gtk-doc/html/cogl
+ --extra-dir=$(COGL_PREFIX)/share/gtk-doc/html/cogl \
+ --extra-dir=$(GDK_PREFIX)/share/gtk-doc/html/gdk \
+ --extra-dir=$(ATK_PREFIX)/share/gtk-doc/html/atk
+
+BUILT_HFILES = \
+ clutter-enum-types.h \
+ clutter-version.h \
+ clutter-marshal.h
-# Used for dependencies. The docs will be rebuilt if any of these change.
-# e.g. HFILE_GLOB=$(top_srcdir)/gtk/*.h
-# e.g. CFILE_GLOB=$(top_srcdir)/gtk/*.c
HFILE_GLOB = \
$(top_srcdir)/clutter/*.h \
$(top_builddir)/clutter/*.h \
@@ -48,10 +34,12 @@ HFILE_GLOB = \
$(top_srcdir)/clutter/wayland/clutter-wayland.h \
$(top_srcdir)/clutter/wayland/clutter-wayland-compositor.h \
$(top_srcdir)/clutter/wayland/clutter-wayland-surface.h \
- $(top_srcdir)/clutter/mir/clutter-mir.h
+ $(top_srcdir)/clutter/mir/clutter-mir.h \
+ $(top_srcdir)/clutter/cally/*.h
CFILE_GLOB = \
$(top_srcdir)/clutter/*.c \
+ $(top_srcdir)/clutter/cally/*.c \
$(top_srcdir)/clutter/cogl/*.c \
$(top_srcdir)/clutter/x11/*.c \
$(top_srcdir)/clutter/win32/*.c \
@@ -62,8 +50,6 @@ CFILE_GLOB = \
$(top_srcdir)/clutter/mir/*.c \
$(top_srcdir)/clutter/deprecated/*.c
-# Header files to ignore when scanning.
-# e.g. IGNORE_HFILES=gtkdebug.h gtkintl.h
IGNORE_HFILES = \
config.h \
clutter.h \
@@ -100,7 +86,7 @@ IGNORE_HFILES = \
clutter-stage-private.h \
clutter-stage-window.h \
clutter-timeout-interval.h \
- cally \
+ cally-actor-private.h \
cex100 \
cogl \
egl \
@@ -126,8 +112,6 @@ EXTRA_HFILES = \
$(top_srcdir)/clutter/wayland/clutter-wayland-surface.h \
$(top_srcdir)/clutter/mir/clutter-mir.h
-# Images to copy into HTML directory.
-# e.g. HTML_IMAGES=$(top_srcdir)/gtk/stock-icons/stock_about_24.png
HTML_IMAGES = \
actor-box.png \
actor-example.png \
@@ -142,13 +126,10 @@ HTML_IMAGES = \
offscreen-redirect.png \
table-layout.png
-# SVG used to generate the images above
SVG_IMAGES = \
animator-key-frames.svg \
easing-modes.svg
-# Extra SGML files that are included by $(DOC_MAIN_SGML_FILE).
-# e.g. content_files=running.sgml building.sgml changes-2.0.sgml
content_files = \
glossary.xml \
clutter-overview.xml \
@@ -159,9 +140,6 @@ content_files = \
migrating-ClutterEffect.xml \
migrating-ClutterPath.xml
-# SGML files where gtk-doc abbrevations (#GtkWidget) are expanded
-# These files must be listed here *and* in content_files
-# e.g. expand_content_files=running.sgml
expand_content_files = \
glossary.xml \
clutter-overview.xml \
@@ -172,26 +150,12 @@ expand_content_files = \
migrating-ClutterEffect.xml \
migrating-ClutterPath.xml
-# CFLAGS and LDFLAGS for compiling gtkdoc-scangobj with your library.
-# Only needed if you are using gtkdoc-scangobj to dynamically query widget
-# signals and properties.
-# e.g. INCLUDES=-I$(top_srcdir) -I$(top_builddir) $(GTK_DEBUG_FLAGS)
-# e.g. GTKDOC_LIBS=$(top_builddir)/gtk/$(gtktargetlib)
-
-AM_CPPFLAGS = \
- -I$(top_srcdir) \
- -I$(top_srcdir)/clutter \
- -I$(top_builddir) \
- -I$(top_builddir)/clutter \
- -DCLUTTER_DISABLE_DEPRECATION_WARNINGS
-AM_CFLAGS = $(CLUTTER_CFLAGS)
+GTKDOC_CFLAGS = -I$(top_srcdir) -I$(top_builddir) -DCLUTTER_DISABLE_DEPRECATION_WARNINGS $(CLUTTER_CFLAGS)
GTKDOC_LIBS = $(top_builddir)/clutter/libclutter-@CLUTTER_API_VERSION@.la $(CLUTTER_LIBS)
-# This includes the standard gtk-doc make rules, copied by gtkdocize.
include $(top_srcdir)/gtk-doc.make
-# Other files to distribute
-# e.g. EXTRA_DIST += version.xml.in
+EXTRA_DIST += clutter.types
EXTRA_DIST += $(HTML_IMAGES) $(SVG_IMAGES)
if ENABLE_GTK_DOC