summaryrefslogtreecommitdiff
path: root/tests/conform/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/conform/meson.build')
-rw-r--r--tests/conform/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/conform/meson.build b/tests/conform/meson.build
index a8da1b398..25c03c794 100644
--- a/tests/conform/meson.build
+++ b/tests/conform/meson.build
@@ -6,11 +6,14 @@ test_cflags = [
test_env = [
'G_ENABLE_DIAGNOSTIC=0',
'CLUTTER_ENABLE_DIAGNOSTIC=0',
- 'CLUTTER_BACKEND=x11',
'G_TEST_SRCDIR=@0@'.format(meson.current_source_dir()),
'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir()),
]
+if enabled_backends.contains('x11')
+ test_env += 'CLUTTER_BACKEND=x11'
+endif
+
actor_tests = [
'actor-anchors',
'actor-destroy',