summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRob Bradford <rob@linux.intel.com>2011-11-07 17:16:13 +0000
committerRobert Bragg <robert@linux.intel.com>2011-11-28 17:37:28 +0000
commit1b54c8023e45b5f5ca6575199acae49d78754fa7 (patch)
treee3d26c8889e29b5b37a5396812abb776be6dc283 /configure.ac
parentd44e548715da619364d4f82e26e83957af38701d (diff)
downloadcogl-1b54c8023e45b5f5ca6575199acae49d78754fa7.tar.gz
kms: Add first version of "baremetal" backend for EGL on KMS
To start with this backend only supports creating a single CoglOnscreen framebuffer and will automatically set is up to display fullscreen on the first suitable crtc it can find. To compile this backend - get some dribbly black candles, sacrifice a goat and configure with: --enable-kms-egl-platform Note: There is currently a problem with using GLES2 with this winsys so you need to run with EGL_DRIVER=gl Note: If you have problems with mesa crashing in XCB during eglInitialize then you may need to explicitly run with EGL_PLATFORM=gbm Reviewed-by: Robert Bragg <robert@linux.intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0f178615..6f3c40f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -755,6 +755,32 @@ AS_IF([test "x$enable_wayland_egl_platform" == "xyes"],
AM_CONDITIONAL(SUPPORT_EGL_PLATFORM_WAYLAND,
[test "x$enable_wayland_egl_platform" = "xyes"])
+
+AC_ARG_ENABLE(
+ [kms-egl-platform],
+ [AC_HELP_STRING([--enable-kms-egl-platform=@<:@no/yes@:>@], [Enable support for the Wayland egl platform @<:@default=no@:>@])],
+ [],
+ enable_kms_egl_platform=no
+)
+AS_IF([test "x$enable_kms_egl_platform" == "xyes"],
+ [
+ EGL_PLATFORM_COUNT=$((EGL_PLATFORM_COUNT+1))
+ NEED_EGL=yes
+ EGL_PLATFORMS="$EGL_PLATFORMS kms"
+
+ PKG_CHECK_EXISTS([gbm],
+ [
+ COGL_PKG_REQUIRES="$COGL_PKG_REQUIRES gbm"
+ COGL_PKG_REQUIRES="$COGL_PKG_REQUIRES libdrm"
+ COGL_PKG_REQUIRES="$COGL_PKG_REQUIRES gl"
+ ],
+ [AC_MSG_ERROR([Unable to locate required kms libraries])])
+
+ COGL_DEFINES_SYMBOLS="$COGL_DEFINES_SYMBOLS COGL_HAS_EGL_PLATFORM_KMS_SUPPORT"
+ ])
+AM_CONDITIONAL(SUPPORT_EGL_PLATFORM_KMS,
+ [test "x$enable_kms_egl_platform" = "xyes"])
+
AC_ARG_ENABLE(
[wayland-egl-server],
[AC_HELP_STRING([--enable-wayland-egl-server=@<:@no/yes@:>@], [Enable server side wayland support @<:@default=no@:>@])],