summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorRobert Bragg <robert@linux.intel.com>2012-09-18 16:44:20 +0100
committerRobert Bragg <robert@linux.intel.com>2013-01-22 17:47:58 +0000
commit04ec48ca538dae44b9a0fb0d8e83100070de7998 (patch)
tree8b44a9c0a234bc81b5aa8c19619db54193f1f70e /examples/Makefile.am
parent41f443971ca18a909ab30f0e92bea2f4c0395a49 (diff)
downloadcogl-04ec48ca538dae44b9a0fb0d8e83100070de7998.tar.gz
build the sdl examples when glib is disabled
This SDL example were unnecessarily including <glib.h> but they don't actually depend on glib so now they are built even if Cogl is being built with --disable-glib. (cherry picked from commit 1d3bce7f68b0a6885c10a29cd9836a3541a1b653)
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am23
1 files changed, 12 insertions, 11 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index ef74da2f..e667afb2 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -60,6 +60,18 @@ cogland_LDADD = $(common_ldadd)
endif
endif
+cogl_gles2_context_SOURCES = cogl-gles2-context.c
+cogl_gles2_context_LDADD = $(common_ldadd)
+
+if BUILD_COGL_GLES2
+programs += cogl-gles2-gears
+cogl_gles2_gears_SOURCES = cogl-gles2-gears.c
+cogl_gles2_gears_CFLAGS = -I$(top_srcdir)/cogl-gles2 $(AM_CFLAGS)
+cogl_gles2_gears_LDADD = $(common_ldadd) $(top_builddir)/cogl-gles2/libcogl-gles2.la
+endif
+
+endif #USE_GLIB
+
if SUPPORT_SDL
programs += cogl-sdl-hello
cogl_sdl_hello_SOURCES = cogl-sdl-hello.c
@@ -72,17 +84,6 @@ cogl_sdl2_hello_SOURCES = cogl-sdl2-hello.c
cogl_sdl2_hello_LDADD = $(common_ldadd)
endif
-cogl_gles2_context_SOURCES = cogl-gles2-context.c
-cogl_gles2_context_LDADD = $(common_ldadd)
-
-if BUILD_COGL_GLES2
-programs += cogl-gles2-gears
-cogl_gles2_gears_SOURCES = cogl-gles2-gears.c
-cogl_gles2_gears_CFLAGS = -I$(top_srcdir)/cogl-gles2 $(AM_CFLAGS)
-cogl_gles2_gears_LDADD = $(common_ldadd) $(top_builddir)/cogl-gles2/libcogl-gles2.la
-endif
-
-endif #USE_GLIB
if INSTALL_EXAMPLES
bin_PROGRAMS = $(programs)