summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorPlamena Manolova <plamena.n.manolova@intel.com>2013-02-22 14:56:05 +0000
committerLionel Landwerlin <llandwerlin@gmail.com>2013-06-21 18:57:24 +0100
commit1eca1631a74f866095b0fc85f2b8b20d82ce2894 (patch)
treeb29e2c4ddeb0da45a9deb914a72047a8fa50f5e4 /examples/Makefile.am
parent29b01c2aba99ed828f43a614b30b49c52a28557f (diff)
downloadcogl-1eca1631a74f866095b0fc85f2b8b20d82ce2894.tar.gz
Include CoglGst
CoglGst is a GStreamer integration library that facilitates video playback using the Cogl API. It works by retrieving each video frame from the GStreamer pipeline and attaching it to a Cogl pipeline in the form of a Cogl texture along with possible color model conversion shaders. The pipeline is then retrieved by the user during each draw. An example use of the CoglGst API is included in the examples directory. Reviewed-by: Neil Roberts <neil@linux.intel.com> (cherry picked from commit dfb94cf4b0b6b42d6465df362a0c0af780596890)
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 332fa137..5ad7cef5 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -50,6 +50,13 @@ cogl_crate_CFLAGS = $(AM_CFLAGS) $(COGL_PANGO_DEP_CFLAGS)
examples_data_DATA += crate.jpg
endif
+if BUILD_COGL_GST
+programs += cogl-basic-video-player
+cogl_basic_video_player_SOURCES = cogl-basic-video-player.c
+cogl_basic_video_player_LDADD = $(common_ldadd) $(COGL_GST_DEP_LIBS) $(top_builddir)/cogl-gst/libcogl-gst.la
+cogl_basic_video_player_CFLAGS = $(AM_CFLAGS) $(COGL_GST_DEP_CFLAGS) -I$(top_builddir)/cogl-gst
+endif
+
if X11_TESTS
programs += cogl-x11-foreign cogl-x11-tfp
cogl_x11_foreign_SOURCES = cogl-x11-foreign.c