summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorRobert Bragg <robert@linux.intel.com>2011-08-23 14:47:35 +0100
committerRobert Bragg <robert@linux.intel.com>2011-10-28 19:10:16 +0100
commit405cacabe23786db93742e0cf17100ae413050bc (patch)
treed4021e0ad202150a4851dd3569797a82972bbd80 /examples/Makefile.am
parentdd7b16faf2cc85c29159442b42ed3f7f46a4dd71 (diff)
downloadcogl-405cacabe23786db93742e0cf17100ae413050bc.tar.gz
examples: Adds a simple 4x msaa example
This adds a very basic test of onscreen and offscreen multisample rendering with 4 samples per pixel. The test simply draws two triangles; the one on the left is rendered directly to the onscreen framebuffer and the other is first rendered offscreen before copying it onscreen. Reviewed-by: Neil Roberts <neil@linux.intel.com>
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 32923205..9abece3b 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -18,12 +18,14 @@ common_ldadd = \
$(COGL_DEP_LIBS) \
$(top_builddir)/cogl/libcogl.la
-programs = cogl-hello
+programs = cogl-hello cogl-msaa
examples_datadir = $(pkgdatadir)/examples-data
examples_data_DATA =
cogl_hello_SOURCES = cogl-hello.c
cogl_hello_LDADD = $(common_ldadd)
+cogl_msaa_SOURCES = cogl-msaa.c
+cogl_msaa_LDADD = $(common_ldadd)
if BUILD_COGL_PANGO
programs += cogl-crate