summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorNeil Roberts <neil@linux.intel.com>2011-09-27 10:27:19 +0100
committerNeil Roberts <neil@linux.intel.com>2011-09-27 10:27:19 +0100
commit5aab8a231090f10ff8de8e40c6fff38e50084655 (patch)
tree196d60173e077c1684c6caa054821e28102f16be /examples/Makefile.am
parent34181d34f523bb4f54ad1d287fd98278622c17f2 (diff)
downloadcogl-5aab8a231090f10ff8de8e40c6fff38e50084655.tar.gz
Add an option to avoid defining G_DISABLE_DEPRECATED
G_DISABLE_DEPRECATED is only intended for developers of Cogl and it sometimes breaks the build for people just trying to build a release. This patch adds an option to enable deprecated Glib features. By default it is enabled for non-git versions of Cogl. The patch is based on similar code in Clutter except it adds the flags to COGL_EXTRA_CFLAGS instead of having a separate variable. Reviewed-by: Robert Bragg <robert@linux.intel.com>
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am5
1 files changed, 0 insertions, 5 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 8b55c09d..1ebe11a7 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -11,11 +11,6 @@ AM_CFLAGS = \
-DCOGL_ENABLE_EXPERIMENTAL_2_0_API \
-DCOGL_EXAMPLES_DATA=\""$(abs_top_srcdir)/examples/"\"
-AM_CPPFLAGS = \
- -DG_DISABLE_SINGLE_INCLUDES \
- -DCOGL_DISABLE_DEPRECATED
-
-
common_ldadd = \
$(COGL_DEP_LIBS) \
$(top_builddir)/cogl/libcogl.la