summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorRobert Bragg <robert@linux.intel.com>2012-09-24 16:42:44 +0100
committerRobert Bragg <robert@linux.intel.com>2013-01-22 17:47:58 +0000
commitab72a2275fd3dcee2f93be83d3d8cf6aa8358f9c (patch)
treea6494886ae0e175829564511504ab1a60d80399e /examples/Makefile.am
parent1c0c1a126a8a5b4156751ec17fdea4720e1fc0b4 (diff)
downloadcogl-ab72a2275fd3dcee2f93be83d3d8cf6aa8358f9c.tar.gz
build: don't include deps/glib headers if glib enabled
If we're using the system glib library then we need to make sure not to include headers under deps/glib otherwise we end up with with incompatible typedefs that break the build. Reviewed-by: Neil Roberts <neil@linux.intel.com> (cherry picked from commit 5d5fc97b59951ec56a4193b7ee7909ebd3cfbb94)
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index e667afb2..7cadaa11 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -1,8 +1,11 @@
include $(top_srcdir)/build/autotools/Makefile.am.silent
INCLUDES = \
- -I$(top_srcdir) \
- -I$(top_builddir)/deps/glib
+ -I$(top_srcdir)
+
+if !USE_GLIB
+INCLUDES += -I$(top_builddir)/deps/glib
+endif
AM_CFLAGS = \
$(COGL_DEP_CFLAGS) \
@@ -17,9 +20,12 @@ endif
common_ldadd = \
$(COGL_DEP_LIBS) \
- $(top_builddir)/deps/glib/libglib.la \
$(top_builddir)/cogl/libcogl.la
+if !USE_GLIB
+common_ldadd += $(top_builddir)/deps/glib/libglib.la
+endif
+
programs = cogl-info
cogl_info_SOURCES = cogl-info.c