summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorRobert Bragg <robert@linux.intel.com>2011-06-15 14:52:21 +0100
committerRobert Bragg <robert@linux.intel.com>2011-06-15 14:52:21 +0100
commitc2bbf90c2ea7fe0dcd63a4a940b2c10ec8a3dae8 (patch)
treeafd85d59d719d274d2133f2c21b2ad4a267f3ed7 /examples/Makefile.am
parent2f000c3c12ed8f454d86e6b92e388dad703ae189 (diff)
downloadcogl-c2bbf90c2ea7fe0dcd63a4a940b2c10ec8a3dae8.tar.gz
examples: pass COGL_DEP_LIBS as ldflags when linking
To be sure our examples link with all the libraries required, we now simply pass the $(COGL_DEP_LIBS) as ldflags when linking them.
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 1084930f..ea69bc83 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -16,6 +16,7 @@ AM_CPPFLAGS = \
common_ldadd = \
+ $(COGL_DEP_LIBS) \
$(top_builddir)/cogl/libcogl.la
noinst_PROGRAMS = hello
@@ -26,7 +27,7 @@ hello_LDADD = $(common_ldadd)
if X11_TESTS
noinst_PROGRAMS += x11-foreign
x11_foreign_SOURCES = x11-foreign.c
-x11_foreign_LDADD = $(common_ldadd) -lX11
+x11_foreign_LDADD = $(common_ldadd)
endif
if SUPPORT_WAYLAND_EGL_SERVER