summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorRobert Bragg <robert@linux.intel.com>2011-03-17 19:32:54 +0000
committerRobert Bragg <robert@linux.intel.com>2011-05-05 14:46:03 +0100
commitf5bb20212bf24d0173c038bcb72e3a93c311e1d8 (patch)
treed813f7a4939660a66fbf5c7dafb0e65d2787c726 /examples/Makefile.am
parent711d035f44243d7ac0db27384974767911210588 (diff)
downloadcogl-f5bb20212bf24d0173c038bcb72e3a93c311e1d8.tar.gz
Adds Cogl Hello World and "X11 foreign" example applications
This adds a simple standalone Cogl application that can be used to smoke test a standalone build of Cogl without Clutter. This also adds an x11-foreign app that shows how a toolkit can ask Cogl to draw to an X Window that it owns instead of Cogl being responsible for automatically creating and mapping an X Window for CoglOnscreen.
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
new file mode 100644
index 00000000..a36befe8
--- /dev/null
+++ b/examples/Makefile.am
@@ -0,0 +1,31 @@
+include $(top_srcdir)/build/autotools/Makefile.am.silent
+
+INCLUDES = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/clutter/cogl \
+ -I$(top_builddir)/clutter/cogl
+
+AM_CFLAGS = \
+ $(COGL_DEP_CFLAGS) \
+ $(COGL_EXTRA_CFLAGS) \
+ -DCOGL_ENABLE_EXPERIMENTAL_2_0_API
+
+AM_CPPFLAGS = \
+ -DG_DISABLE_SINGLE_INCLUDES \
+ -DCOGL_DISABLE_DEPRECATED
+
+
+common_ldadd = \
+ $(top_builddir)/cogl/libcogl.la \
+ $(top_builddir)/pango/libcoglpango.la
+
+noinst_PROGRAMS = hello
+
+hello_SOURCES = hello.c
+hello_LDADD = $(common_ldadd)
+
+if X11_TESTS
+noinst_PROGRAMS += x11-foreign
+x11_foreign_SOURCES = x11-foreign.c
+x11_foreign_LDADD = $(common_ldadd)
+endif