summaryrefslogtreecommitdiff
path: root/data/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'data/meson.build')
-rw-r--r--data/meson.build38
1 files changed, 38 insertions, 0 deletions
diff --git a/data/meson.build b/data/meson.build
new file mode 100644
index 0000000..2d104fb
--- /dev/null
+++ b/data/meson.build
@@ -0,0 +1,38 @@
+subdir('icons')
+subdir('ui')
+
+desktop_conf = configuration_data()
+desktop_conf.set('PACKAGE', df_name)
+
+desktop = df_namespace + '.desktop'
+
+desktop_in = configure_file(
+ input: desktop + '.in.in',
+ output: '@BASENAME@',
+ configuration: desktop_conf,
+)
+
+custom_target(
+ desktop,
+ input: desktop_in,
+ output: '@BASENAME@',
+ command: intltool_desktop_cmd,
+ install: true,
+ install_dir: df_datadir / 'applications',
+)
+
+appdata = df_namespace + '.appdata.xml'
+
+custom_target(
+ appdata,
+ input: appdata + '.in',
+ output: '@BASENAME@',
+ command: intltool_xml_cmd,
+ install: true,
+ install_dir: df_datadir / 'metainfo',
+)
+
+install_data(
+ df_namespace + '.gschema.xml',
+ install_dir: gio_schemasdir,
+)