summaryrefslogtreecommitdiff
path: root/src/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/tests/Makefile.am')
-rw-r--r--src/tests/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/tests/Makefile.am b/src/tests/Makefile.am
index d641dc7..5f61ae1 100644
--- a/src/tests/Makefile.am
+++ b/src/tests/Makefile.am
@@ -6,7 +6,9 @@ EXTRA_DIST = tests.py.in
CLEANFILES = $(check_SCRIPTS)
tests.py: tests.py.in
- $(AM_V_GEN) sed -e 's|@PYTHON[@]|$(PYTHON)|g' $< > $@
+ $(AM_V_GEN) sed -e 's|@PYTHON[@]|$(PYTHON)|g' \
+ -e 's|@DATA_DIR[@]|$(top_srcdir)/data|g' \
+ -e 's|@SRC_DIR[@]|$(top_srcdir)|g' $< > $@
chmod +x $@
# Default pycodestyle --exclude + emacs backup files