summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMichael Catanzaro <mcatanzaro@redhat.com>2023-02-02 12:20:25 -0600
committerMarge Bot <marge-bot@gnome.org>2023-02-02 22:18:11 +0000
commit270d54a5ef9a3c9cb96997dbe0fbcb329dbf80e8 (patch)
tree117f2977f80630c08000d0a6312db0c296d76472 /meson.build
parenteb0ad9f4446e383b286bfc48665b4355cca1c8bb (diff)
downloadglib-networking-270d54a5ef9a3c9cb96997dbe0fbcb329dbf80e8.tar.gz
Remove static_modules build option
The option is deprecated because it's not useful, but the functionality is not deprecated. This will avoid future confusion at the expense of breaking anybody who is currently using the option. Related: #206 Part-of: <https://gitlab.gnome.org/GNOME/glib-networking/-/merge_requests/233>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index ec6065a..d2d0908 100644
--- a/meson.build
+++ b/meson.build
@@ -33,7 +33,7 @@ common_flags = [
'-DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_70'
]
-build_static = get_option('static_modules') or get_option('default_library') != 'shared'
+build_static = get_option('default_library') != 'shared'
build_shared = get_option('default_library') != 'static'
if build_static and build_shared and (host_system == 'windows' or host_system == 'cygwin')
error('On Windows default_library must be "shared" or "static" but not "both"')