summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJeffrey Stedfast <fejj@ximian.com>2002-06-26 05:31:47 +0000
committerJeffrey Stedfast <fejj@src.gnome.org>2002-06-26 05:31:47 +0000
commit41169220628641dea4f0575e0629aebc73bb2a5c (patch)
tree322b229e933dcf3e50208e2a3aabb093b3a1be90 /Makefile.am
parent3d2b05dc16ba989601ce76c221564f3911fabe0c (diff)
downloadgmime-41169220628641dea4f0575e0629aebc73bb2a5c.tar.gz
New test suite for the pgp/mime code.
2002-06-26 Jeffrey Stedfast <fejj@ximian.com> * test-pgpmime.c: New test suite for the pgp/mime code. * gmime-gpg-context.c (gpg_ctx_parse_status): Handle a NODATA status message from gpg. * gmime-message.c (g_mime_message_new): Don't set NULL header values via the g_mime_object_set_header interface. * gmime-object.c (g_mime_object_add_header): Don't allow value == NULL. (g_mime_object_set_header): Same. * gmime.h.in: Updated to #include the new headers related to encryption and digital signatures. * gmime.c (g_mime_init): register the multipart/encrypted and multipart/signed cclass types. * gmime-multipart-signed.c: Fixed to compile cleanly. (multipart_signed_write_to_stream): We need to handle writing out the subparts ourselves because we need to armor From-lines. * gmime-multipart-encrypted.c: Fixed to compile cleanly.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am178
1 files changed, 95 insertions, 83 deletions
diff --git a/Makefile.am b/Makefile.am
index 7884ebcc..3884d7e0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,7 +15,8 @@ noinst_PROGRAMS = \
test-html \
test-iconv \
test-partial \
- test-pgp
+ test-pgp \
+ test-pgpmime
bin_SCRIPTS = gmime-config
@@ -23,90 +24,96 @@ lib_LTLIBRARIES = libgmime-2.0.la
libgmime_2_0_la_LDFLAGS = -version-info @GMIME_VERSION_INFO@
-libgmime_2_0_la_SOURCES = \
- alloca.c \
- strlib.c \
- memchunk.c \
- gmime.c \
- gmime-charset.c \
- gmime-cipher-context.c \
- gmime-content-type.c \
- gmime-data-wrapper.c \
- gmime-disposition.c \
- gmime-exception.c \
- gmime-filter.c \
- gmime-filter-basic.c \
- gmime-filter-charset.c \
- gmime-filter-crlf.c \
- gmime-filter-from.c \
- gmime-filter-html.c \
- gmime-filter-yenc.c \
- gmime-gpg-context.c \
- gmime-header.c \
- gmime-iconv.c \
- gmime-iconv-utils.c \
- gmime-message.c \
- gmime-message-part.c \
- gmime-message-partial.c \
- gmime-multipart.c \
- gmime-object.c \
- gmime-param.c \
- gmime-parser.c \
- gmime-part.c \
- gmime-session.c \
- gmime-stream.c \
- gmime-stream-buffer.c \
- gmime-stream-cat.c \
- gmime-stream-file.c \
- gmime-stream-filter.c \
- gmime-stream-fs.c \
- gmime-stream-mem.c \
- gmime-stream-mmap.c \
- gmime-stream-null.c \
- gmime-utils.c \
- internet-address.c \
+libgmime_2_0_la_SOURCES = \
+ alloca.c \
+ strlib.c \
+ memchunk.c \
+ gmime.c \
+ gmime-charset.c \
+ gmime-cipher-context.c \
+ gmime-content-type.c \
+ gmime-data-wrapper.c \
+ gmime-disposition.c \
+ gmime-exception.c \
+ gmime-filter.c \
+ gmime-filter-basic.c \
+ gmime-filter-charset.c \
+ gmime-filter-crlf.c \
+ gmime-filter-from.c \
+ gmime-filter-html.c \
+ gmime-filter-strip.c \
+ gmime-filter-yenc.c \
+ gmime-gpg-context.c \
+ gmime-header.c \
+ gmime-iconv.c \
+ gmime-iconv-utils.c \
+ gmime-message.c \
+ gmime-message-part.c \
+ gmime-message-partial.c \
+ gmime-multipart.c \
+ gmime-multipart-encrypted.c \
+ gmime-multipart-signed.c \
+ gmime-object.c \
+ gmime-param.c \
+ gmime-parser.c \
+ gmime-part.c \
+ gmime-session.c \
+ gmime-stream.c \
+ gmime-stream-buffer.c \
+ gmime-stream-cat.c \
+ gmime-stream-file.c \
+ gmime-stream-filter.c \
+ gmime-stream-fs.c \
+ gmime-stream-mem.c \
+ gmime-stream-mmap.c \
+ gmime-stream-null.c \
+ gmime-utils.c \
+ internet-address.c \
md5-utils.c
gmimeincludedir = $(includedir)/gmime-2.0
-gmimeinclude_HEADERS = \
- gmime.h \
- gmime-charset.h \
- gmime-cipher-context.h \
- gmime-content-type.h \
- gmime-data-wrapper.h \
- gmime-disposition.h \
- gmime-exception.h \
- gmime-exception-list.def\
- gmime-filter.h \
- gmime-filter-basic.h \
- gmime-filter-charset.h \
- gmime-filter-crlf.h \
- gmime-filter-from.h \
- gmime-filter-html.h \
- gmime-filter-yenc.h \
- gmime-gpg-context.h \
- gmime-header.h \
- gmime-iconv.h \
- gmime-iconv-utils.h \
- gmime-message.h \
- gmime-message-part.h \
- gmime-message-partial.h \
- gmime-multipart.h \
- gmime-object.h \
- gmime-param.h \
- gmime-parser.h \
- gmime-part.h \
- gmime-session.h \
- gmime-stream.h \
- gmime-stream-buffer.h \
- gmime-stream-cat.h \
- gmime-stream-file.h \
- gmime-stream-filter.h \
- gmime-stream-fs.h \
- gmime-stream-mem.h \
- gmime-stream-mmap.h \
- gmime-stream-null.h \
- gmime-utils.h \
+gmimeinclude_HEADERS = \
+ gmime.h \
+ gmime-charset.h \
+ gmime-cipher-context.h \
+ gmime-content-type.h \
+ gmime-data-wrapper.h \
+ gmime-disposition.h \
+ gmime-exception.h \
+ gmime-exception-list.def \
+ gmime-filter.h \
+ gmime-filter-basic.h \
+ gmime-filter-charset.h \
+ gmime-filter-crlf.h \
+ gmime-filter-from.h \
+ gmime-filter-html.h \
+ gmime-filter-strip.h \
+ gmime-filter-yenc.h \
+ gmime-gpg-context.h \
+ gmime-header.h \
+ gmime-iconv.h \
+ gmime-iconv-utils.h \
+ gmime-message.h \
+ gmime-message-part.h \
+ gmime-message-partial.h \
+ gmime-multipart.h \
+ gmime-multipart-encrypted.h \
+ gmime-multipart-signed.h \
+ gmime-object.h \
+ gmime-param.h \
+ gmime-parser.h \
+ gmime-part.h \
+ gmime-session.h \
+ gmime-stream.h \
+ gmime-stream-buffer.h \
+ gmime-stream-cat.h \
+ gmime-stream-file.h \
+ gmime-stream-filter.h \
+ gmime-stream-fs.h \
+ gmime-stream-mem.h \
+ gmime-stream-mmap.h \
+ gmime-stream-null.h \
+ gmime-utils.h \
internet-address.h
noinst_HEADERS = \
@@ -159,6 +166,11 @@ test_pgp_LDFLAGS =
test_pgp_DEPENDENCIES = $(DEPS)
test_pgp_LDADD = $(LDADDS)
+test_pgpmime_SOURCES = test-pgpmime.c
+test_pgpmime_LDFLAGS =
+test_pgpmime_DEPENDENCIES = $(DEPS)
+test_pgpmime_LDADD = $(LDADDS)
+
gen_table_SOURCES = gen-table.c
gen_table_LDFLAGS =
gen_table_DEPENDENCIES =
@@ -195,7 +207,7 @@ ICONVtests : test-iconv
@echo "## iconv cache regression tests"
@echo "##"
-PGPtests : test-pgp
+PGPtests : test-pgp test-pgpmime
@echo "##"
@echo "## PGP tests"
@echo "##"