summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJeffrey Stedfast <fejj@ximian.com>2002-06-25 02:00:26 +0000
committerJeffrey Stedfast <fejj@src.gnome.org>2002-06-25 02:00:26 +0000
commitef44cb97bd7ecb6c68e9ab2fc552ed22026d3c7e (patch)
tree2e816f8bcaf2b3b81c86a2a374e6b2ae5d53bd1a /Makefile.am
parente412d1d0a564fd81dbba1247471f0a8b18bc3f80 (diff)
downloadgmime-ef44cb97bd7ecb6c68e9ab2fc552ed22026d3c7e.tar.gz
Register as a subclass of a GMimeMultipart.
2002-06-24 Jeffrey Stedfast <fejj@ximian.com> * gmime-multipart-signed.c (g_mime_multipart_signed_get_type): Register as a subclass of a GMimeMultipart. * gmime-multipart-encrypted.c (g_mime_multipart_encrypted_get_type): Same. * gmime-gpg-context.[c,h]: A new class implementing the GMimeCipherContext interfaces for GnuPG. * gmime-session.[c,h]: New abstract session class for use by the cipher context classes for requesting passphrases/etc. * gmime-cipher-context.c (g_mime_cipher_context_finalize): Unref the gmime-session.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f84646ef..3770062b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,9 +20,11 @@ libgmime_2_0_la_SOURCES = \
memchunk.c \
gmime.c \
gmime-charset.c \
+ gmime-cipher-context.c \
gmime-content-type.c \
gmime-data-wrapper.c \
gmime-disposition.c \
+ gmime-exception.c \
gmime-filter.c \
gmime-filter-basic.c \
gmime-filter-charset.c \
@@ -30,6 +32,7 @@ libgmime_2_0_la_SOURCES = \
gmime-filter-from.c \
gmime-filter-html.c \
gmime-filter-yenc.c \
+ gmime-gpg-context.c \
gmime-header.c \
gmime-iconv.c \
gmime-iconv-utils.c \
@@ -41,6 +44,7 @@ libgmime_2_0_la_SOURCES = \
gmime-param.c \
gmime-parser.c \
gmime-part.c \
+ gmime-session.c \
gmime-stream.c \
gmime-stream-buffer.c \
gmime-stream-cat.c \
@@ -58,9 +62,11 @@ gmimeincludedir = $(includedir)/gmime-2.0
gmimeinclude_HEADERS = \
gmime.h \
gmime-charset.h \
+ gmime-cipher-context.h \
gmime-content-type.h \
gmime-data-wrapper.h \
gmime-disposition.h \
+ gmime-exception.h \
gmime-filter.h \
gmime-filter-basic.h \
gmime-filter-charset.h \
@@ -68,6 +74,7 @@ gmimeinclude_HEADERS = \
gmime-filter-from.h \
gmime-filter-html.h \
gmime-filter-yenc.h \
+ gmime-gpg-context.h \
gmime-header.h \
gmime-iconv.h \
gmime-iconv-utils.h \
@@ -79,6 +86,7 @@ gmimeinclude_HEADERS = \
gmime-param.h \
gmime-parser.h \
gmime-part.h \
+ gmime-session.h \
gmime-stream.h \
gmime-stream-buffer.h \
gmime-stream-cat.h \