summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJeffrey Stedfast <fejj@ximian.com>2002-05-12 04:12:08 +0000
committerJeffrey Stedfast <fejj@src.gnome.org>2002-05-12 04:12:08 +0000
commitf871f45da0c3f63d4c8deee3fe4b41cce476ab0a (patch)
tree35ae424519b07ad5bdb9d79a683006a13e7aac1a /Makefile.am
parent05db42ab62845756a8e84e808f021727690ee8f5 (diff)
downloadgmime-f871f45da0c3f63d4c8deee3fe4b41cce476ab0a.tar.gz
New test suite for gmime-message-partial.c.
2002-05-12 Jeffrey Stedfast <fejj@ximian.com> * test-partial.c: New test suite for gmime-message-partial.c. * gmime-stream-cat.c: Several fixes. (g_mime_stream_cat_class_init): Overload the seek method. * gmime-stream-mmap.c (g_mime_stream_mmap_class_init): Overload the seek method. * gmime-stream-buffer.c (g_mime_stream_buffer_class_init): Overload the seek method. * gmime-stream-null.c (g_mime_stream_null_class_init): Overload the seek method. * gmime-stream-filter.c (g_mime_stream_filter_class_init): Overload the seek method. * gmime-stream.c (g_mime_stream_class_init): Overload the seek method. * gmime-stream-mem.c (g_mime_stream_mem_class_init): Overload the seek method. * gmime-stream-file.c (g_mime_stream_file_class_init): Overload the seek method. (stream_length): The length of the stream is bound_end - bound_start. * gmime-stream-fs.c (g_mime_stream_fs_class_init): Overload the seek method. (stream_length): The length of the stream is bound_end - bound_start.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 30989961..96c8ada9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,7 +6,7 @@ INCLUDES = -I@srcdir@ $(VERSION_FLAGS) @GLIB_CFLAGS@ -DG_LOG_DOMAIN=\"gmime\"
VERSION_FLAGS = -DGMIME_VERSION=\"@GMIME_VERSION@\"
-noinst_PROGRAMS = gen-table test-mime test-parser test-mbox test-streams test-html test-iconv
+noinst_PROGRAMS = gen-table test-mime test-parser test-mbox test-streams test-html test-iconv test-partial
bin_SCRIPTS = gmime-config
@@ -129,6 +129,11 @@ test_iconv_LDFLAGS =
test_iconv_DEPENDENCIES = $(DEPS)
test_iconv_LDADD = $(LDADDS)
+test_partial_SOURCES = test-partial.c
+test_partial_LDFLAGS =
+test_partial_DEPENDENCIES = $(DEPS)
+test_partial_LDADD = $(LDADDS)
+
gen_table_SOURCES = gen-table.c
gen_table_LDFLAGS =
gen_table_DEPENDENCIES =
@@ -145,7 +150,7 @@ MIMEtests : test-mime
@echo "## MIME regression tests"
@echo "##"
-PARSERtests : test-parser test-mbox
+PARSERtests : test-parser test-mbox test-partial
@echo "##"
@echo "## MIME Parser regression tests"
@echo "##"