summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2020-09-23 12:22:01 +0200
committerBastien Nocera <hadess@hadess.net>2020-09-23 12:22:01 +0200
commitf8706c33f2959b93e06ce386c9a067ad57e96042 (patch)
treea6361462055081c46a5dda4980a9a49730f8e443 /meson.build
parent08defddc2cdcff7f5d783de46c2fddb654c5aeed (diff)
downloadgnome-bluetooth-f8706c33f2959b93e06ce386c9a067ad57e96042.tar.gz
build: Add check-news.sh helper
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 02f11fbf..357b4eb8 100644
--- a/meson.build
+++ b/meson.build
@@ -133,3 +133,9 @@ output += ' Prefix......................: ' + gnomebt_prefix + '\n'
output += ' Documentation...............: ' + enable_gtk_doc.to_string() + '\n'
output += ' GObject-Introspection.......: ' + enable_gir.to_string()
message(output)
+
+meson.add_dist_script(
+ find_program('check-news.sh').path(),
+ '@0@'.format(meson.project_version()),
+ 'NEWS',
+)