summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMichael Catanzaro <mcatanzaro@gnome.org>2019-12-06 14:06:41 -0600
committerMichael Catanzaro <mcatanzaro@gnome.org>2019-12-06 14:06:41 -0600
commit9766cd1858e380ca3ed5b68e0a5f911d5bb2f801 (patch)
tree8b0112d9b0a743ecbe5ebae21c19db365f5a5c81 /meson.build
parent2be799d78d979e47ce43941730a72fe00fffc993 (diff)
downloadgnome-calendar-9766cd1858e380ca3ed5b68e0a5f911d5bb2f801.tar.gz
Fix app ID outside devel profile
We accidentally have a trailing period here except when the Devel profile is selected, which is not a valid app ID.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index ecf1dc96..3adc3af4 100644
--- a/meson.build
+++ b/meson.build
@@ -46,7 +46,11 @@ else
rev = ''
endif
-application_id = 'org.gnome.Calendar.@0@'.format(profile)
+if profile == ''
+ application_id = 'org.gnome.Calendar'
+else
+ application_id = 'org.gnome.Calendar.@0@'.format(profile)
+endif
calendar_buildtype = get_option('buildtype')
calendar_debug = calendar_minor_version.is_odd() or calendar_buildtype.contains('debug')
enable_tracing = get_option('tracing')