summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNiels De Graef <nielsdegraef@gmail.com>2020-12-04 11:36:36 +0100
committerNiels De Graef <nielsdegraef@gmail.com>2020-12-04 11:36:36 +0100
commit07c4a336a0fbc8860c8164385d4732a9e4c82b0a (patch)
treee1be7ae965e2c3e581ca9f0dd0f417288aa87d21 /meson.build
parent1e45863422010984fe541bfd1f6d5216d960f7af (diff)
downloadgnome-contacts-07c4a336a0fbc8860c8164385d4732a9e4c82b0a.tar.gz
Remove libhandy git submodule / meson subproject
libhandy has reached a stable point, so distributions should start including it as a proper package rather than relying on a git submodule. This also fixes some small annoyances in the build system.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build31
1 files changed, 3 insertions, 28 deletions
diff --git a/meson.build b/meson.build
index 7eaeed8..eb4da23 100644
--- a/meson.build
+++ b/meson.build
@@ -10,9 +10,6 @@ i18n = import('i18n')
# Add our custom VAPI dir
add_project_arguments(
['--vapidir', meson.source_root() / 'vapi'],
- # We need to add this, since Vala queries the pkgconfig version on its own
- # and will error out if that is lower then required one
- '--disable-since-check',
language: 'vala'
)
@@ -53,10 +50,12 @@ gmodule_export = dependency('gmodule-export-2.0', version: '>=' + min_glib_versi
gnome_desktop = dependency('gnome-desktop-3.0')
goa = dependency('goa-1.0')
gtk = dependency('gtk+-3.0', version: '>= 3.23.1')
+libhandy = dependency('libhandy-1', version: '>= 1.0.0')
+# E-D-S
libebook = dependency('libebook-1.2', version: '>=' + min_eds_version)
libedataserver = dependency('libedataserver-1.2', version: '>=' + min_eds_version)
libedataserverui = dependency('libedataserverui-1.2', version: '>=' + min_eds_version)
-
+# Cheese
cheese_dep = dependency('cheese', required: get_option('cheese'))
cheese_gtk_dep = dependency('cheese-gtk', version: '>= 3.3.91', required: get_option('cheese'))
@@ -65,30 +64,6 @@ if get_option('telepathy')
telepathy_glib = dependency('telepathy-glib', version: '>= 0.22.0')
endif
-libhandy = dependency('libhandy-1', version: '>= 1.0.0', required: false)
-if not libhandy.found()
- libhandy_subproj = subproject(
- 'libhandy',
- default_options: [
- 'examples=false',
- 'glade_catalog=disabled',
- 'tests=false',
- ]
- )
-
- # When using libhandy as subproject, make sure we get the VAPI file
- libhandy = declare_dependency(
- dependencies: [
- libhandy_subproj.get_variable('libhandy_dep'),
- libhandy_subproj.get_variable('libhandy_vapi'),
- ]
- )
-
- libhandy_vapidir = meson.build_root() / 'subprojects' / 'libhandy' / 'src'
-else
- libhandy_vapidir = ''
-endif
-
valadoc = find_program('valadoc', required: get_option('docs'))