summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2020-09-21 21:24:59 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2020-09-21 22:02:13 +0100
commitd792ccf10bca5d2ab8e7e3c423daff0c39f21f19 (patch)
tree64aeb16623a7980b9fb036fda8c1ada5d368818e /meson.build
parentbe351769305e4186ac52533d6ae19e21bc5d1428 (diff)
downloadgnome-dictionary-d792ccf10bca5d2ab8e7e3c423daff0c39f21f19.tar.gz
Add a development profile
We begin the GNOME 40 development cycle by adding the ability to define a development build of Dictionary, with its own application identifier. We use the same application identifier across the binary, so that the shell can match our desktop file with it; and we use a different label in the About dialog, depending on whether we are using a development build or not. It's possible to enable the development build by using a build option; otherwise, we're going to check if the current version is one of the three development stages of a GNOME release.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 12 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 9a3d52d..3be6c46 100644
--- a/meson.build
+++ b/meson.build
@@ -1,4 +1,4 @@
-project('gnome-dictionary', 'c', version: '3.26.2',
+project('gnome-dictionary', 'c', version: '40.alpha',
default_options: [
'buildtype=debugoptimized',
'c_std=c99',
@@ -7,6 +7,10 @@ project('gnome-dictionary', 'c', version: '3.26.2',
license: 'GPLv2+',
meson_version: '>= 0.54.0')
+gdict_version = meson.project_version().split('.')
+gdict_major_version = gdict_version[0].to_int()
+gdict_minor_version = gdict_version[1]
+
# Paths for the pkg-config file
gdict_prefix = get_option('prefix')
gdict_bindir = gdict_prefix / get_option('bindir')
@@ -70,11 +74,18 @@ endif
common_cflags = cc.get_supported_arguments(test_cflags)
+profile = get_option('profile')
debug = get_option('debug')
optimization = get_option('optimization')
buildtype = get_option('buildtype')
debug_cflags = []
+if profile == 'devel' or gdict_minor_version in ['alpha', 'beta', 'rc']
+ application_id = 'org.gnome.Dictionary.Devel'
+else
+ application_id = 'org.gnome.Dictionary'
+endif
+
if debug
debug_cflags += '-DGDICT_ENABLE_DEBUG'
elif optimization in ['2', '3', 's']