summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGeorges Basile Stavracas Neto <georges.stavracas@gmail.com>2022-07-16 10:02:29 -0300
committerGeorges Basile Stavracas Neto <georges.stavracas@gmail.com>2022-07-25 15:40:13 -0300
commit7665c1d8c7f394ac907852770e3e2d45ec7ed823 (patch)
tree266f62ec0486022224f8324834c9bab74a521a4b /meson.build
parente436ef58c4d5a85e9e5ad605eb156246c5830545 (diff)
downloadgnome-initial-setup-7665c1d8c7f394ac907852770e3e2d45ec7ed823.tar.gz
parental-controls: Port to GTK4
Most of the porting work is done in libmalcontent-ui [1] already, this page merely consumes the available widgetry. [1] https://gitlab.freedesktop.org/pwithnall/malcontent/-/merge_requests/141
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 51406bc..80659b0 100644
--- a/meson.build
+++ b/meson.build
@@ -58,8 +58,9 @@ libmalcontent_dep = dependency ('malcontent-0',
version: '>= 0.6.0',
required: get_option('parental_controls'))
libmalcontent_ui_dep = dependency ('malcontent-ui-0',
- version: '>= 0.6.0',
- required: get_option('parental_controls'))
+ version: '>= 0.11.0',
+ required: get_option('parental_controls'),
+ fallback: ['malcontent-ui', 'libmalcontent_ui_dep'])
have_parental_controls = libmalcontent_dep.found() and libmalcontent_ui_dep.found()
conf.set('HAVE_PARENTAL_CONTROLS', have_parental_controls)