summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMichael Catanzaro <mcatanzaro@redhat.com>2021-07-30 10:10:47 -0500
committerMarge Bot <marge-bot@gnome.org>2021-08-10 09:40:51 +0000
commit7d727575910e2810652b23273112fd569761ddf4 (patch)
tree9baecdc913d33cc037c0513348c86b697bd7a789 /meson.build
parent0b49827923a3d6679dea566a17dc5bb9a7589a47 (diff)
downloadgnome-initial-setup-7d727575910e2810652b23273112fd569761ddf4.tar.gz
Revert "Remove obsolete Software page"
This reverts commit 7451f79ec7d9dac266ee51674166b072083f7e92. This brings back the software page that was previously removed because it was broken for a long time, #59. I will be updating it in subsequent commits to actually work. Part-of: <https://gitlab.gnome.org/GNOME/gnome-initial-setup/-/merge_requests/121>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 6f12969..7ca342c 100644
--- a/meson.build
+++ b/meson.build
@@ -54,6 +54,12 @@ cheese_gtk_dep = dependency ('cheese-gtk',
required: get_option('cheese'))
conf.set('HAVE_CHEESE', cheese_dep.found() and cheese_gtk_dep.found())
+# Needed for the 'software' page
+pkgkit_dep = dependency ('packagekit-glib2',
+ version: '>= 1.1.4',
+ required: get_option('software-sources'))
+conf.set('ENABLE_SOFTWARE_SOURCES', pkgkit_dep.found())
+
# Needed for the 'keyboard' page
ibus_dep = dependency ('ibus-1.0',
version: '>= 1.4.99',