summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGeorges Basile Stavracas Neto <georges.stavracas@gmail.com>2022-07-25 18:49:05 +0000
committerGeorges Basile Stavracas Neto <georges.stavracas@gmail.com>2022-07-25 18:49:05 +0000
commita258f1cb02e6994d208d50171a7a4869c63b19ca (patch)
treec42ea3b5115f5473cb1bd5ddeb26453424ee284b /meson.build
parent0ad1ce51c1155ef0b7f30a878a514267ce1344d2 (diff)
parentf763ed2c8255890e5705c5e11dedbb9d475a563e (diff)
downloadgnome-initial-setup-a258f1cb02e6994d208d50171a7a4869c63b19ca.tar.gz
Merge branch 'wip/port-to-gtk4' into 'master'
GTK4 Closes #131 e #81 See merge request GNOME/gnome-initial-setup!134
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build27
1 files changed, 14 insertions, 13 deletions
diff --git a/meson.build b/meson.build
index 8a3718f..bab863a 100644
--- a/meson.build
+++ b/meson.build
@@ -26,6 +26,7 @@ conf.set_quoted('PKGDATADIR', pkgdata_dir)
conf.set_quoted('DATADIR', data_dir)
conf.set_quoted('PKGSYSCONFDIR', pkgsysconf_dir)
conf.set_quoted('SYSCONFDIR', sysconf_dir)
+conf.set_quoted('LIBEXECDIR', libexec_dir)
conf.set('SECRET_API_SUBJECT_TO_CHANGE', true)
conf.set_quoted('G_LOG_DOMAIN', 'InitialSetup')
conf.set('GLIB_VERSION_MIN_REQUIRED', 'GLIB_VERSION_2_64')
@@ -47,16 +48,6 @@ if vendor_conf_file != ''
conf.set_quoted('VENDOR_CONF_FILE', vendor_conf_file)
endif
-# Needed for the 'account' page
-cheese_dep = dependency ('cheese',
- version: '>= 3.28',
- required: get_option('cheese'))
-cheese_gtk_dep = dependency ('cheese-gtk',
- version: '>= 3.3.5',
- required: get_option('cheese'))
-have_cheese = cheese_dep.found() and cheese_gtk_dep.found()
-conf.set('HAVE_CHEESE', have_cheese)
-
# Needed for the 'keyboard' page
ibus_dep = dependency ('ibus-1.0',
version: '>= 1.4.99',
@@ -64,13 +55,24 @@ ibus_dep = dependency ('ibus-1.0',
have_ibus = ibus_dep.found()
conf.set('HAVE_IBUS', have_ibus)
+# Check for libadwaita before malcontent-ui, otherwise Meson may search and
+# find an older version of libadwaita in the host system, cache it, and fail
+# to fallback to a submodule.
+libadwaita_dep = dependency(
+ 'libadwaita-1',
+ version: '>= 1.2.alpha',
+ fallback: ['libadwaita', 'libadwaita_dep'],
+ default_options: ['examples=false', 'introspection=disabled', 'tests=false', 'vapi=false'],
+)
+
# Needed for the parental controls pages
libmalcontent_dep = dependency ('malcontent-0',
version: '>= 0.6.0',
required: get_option('parental_controls'))
libmalcontent_ui_dep = dependency ('malcontent-ui-0',
- version: '>= 0.6.0',
- required: get_option('parental_controls'))
+ version: '>= 0.11.0',
+ required: get_option('parental_controls'),
+ fallback: ['malcontent-ui', 'libmalcontent_ui_dep'])
have_parental_controls = libmalcontent_dep.found() and libmalcontent_ui_dep.found()
conf.set('HAVE_PARENTAL_CONTROLS', have_parental_controls)
@@ -86,7 +88,6 @@ subdir('build-aux')
summary(
{
'systemd support': enable_systemd,
- 'Cheese': have_cheese,
'IBus': have_ibus,
'Parental Controls': have_parental_controls,
'Vendor Configuration File':