summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMichael Catanzaro <mcatanzaro@redhat.com>2021-08-05 14:46:49 -0500
committerMarge Bot <marge-bot@gnome.org>2021-08-10 09:40:51 +0000
commitba2105ad2afcacb68539915b8cc975e40c59624c (patch)
treea90bb63102f40a1c766633015404cae3ef00a9b0 /meson.build
parenteedb59a93656ae09f71fa1a2c389320331729fa9 (diff)
downloadgnome-initial-setup-ba2105ad2afcacb68539915b8cc975e40c59624c.tar.gz
Add polkit rule to allow executing fedora-third-party
This is based on an Endless commit by Philip Chimento. Note that gnome-initial-setup will execute fedora-third-party wherever it is found in PATH, since there is some debugging benefit to allowing this, but it will require a password prompt unless it's the trusted version of the script installed in bindir. Part-of: <https://gitlab.gnome.org/GNOME/gnome-initial-setup/-/merge_requests/121>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 6f12969..c31ff8d 100644
--- a/meson.build
+++ b/meson.build
@@ -2,7 +2,7 @@ project('gnome-initial-setup',
['c'],
version: '41.beta',
license: 'GPLv2',
- meson_version: '>= 0.49.0',
+ meson_version: '>= 0.50.0',
)
cc = meson.get_compiler('c')
@@ -11,6 +11,7 @@ i18n = import('i18n')
prefix = get_option('prefix')
po_dir = join_paths(meson.source_root(), 'po')
+bin_dir = join_paths(prefix, get_option('bindir'))
data_dir = join_paths(prefix, get_option('datadir'))
locale_dir = join_paths(prefix, get_option('localedir'))
libexec_dir = join_paths(prefix, get_option('libexecdir'))